How do I fix this screwed up album?

Discussion in 'iOS 6' started by MXSkier62, Oct 18, 2012.

  1. MXSkier62 macrumors regular

    Dec 4, 2006
    So I've had this problem with this album, and others like it, for a while. The album isn't one main album, it shows every artist instead of it just being the compilation. Newer albums don't really have this problem, only this one.

    How do I fix this? I've tried to click "part of a compilation" and it doesn't work. Ideas?

    Attached Files:

  2. BrokeTechLover macrumors regular

    Jul 4, 2012
    Have you tried changing the album artist to the same thing,such as Various?
  3. peeaanuut macrumors 65816

    Sep 10, 2007
    Southern California
    on those types of things I would either put an "album artist" as various or choose compilation.
  4. MXSkier62 thread starter macrumors regular

    Dec 4, 2006
    I've tried those with other albums, but it makes it impossible to find a specific artist later that way. I have other compilation albums or albums with multiple artists that don't do this, it's only a few. And with the new iTunes 11 format, it's going to be really annoying.
  5. Diode macrumors 68020


    Apr 15, 2004
    Washington DC
    You try fooling around with the "group by album artist" setting? Ie set the album artist as the soundtrack for all of the songs and leave the individual artist the same.

    You can find that option under settings->music

    Oh wait - didn't fully read above :(
  6. peeaanuut macrumors 65816

    Sep 10, 2007
    Southern California
    There are a few other things that could be going on. I frequently get top 40 groupings of songs. The albums all say XX Top 40 XXXXdate or something along those lines. The artist is correct to whatever the artist is but the album says top 40. I go in and put the correct album for the track and make sure the artist is correct, I then use the album artist to put in Top 40 and the date and chart, etc. I then sometimes will check the compilation tag, but not always depending on what it is I want it to do. So I can then find it by artist, album or top 40 chart or date depending on how I want to sort it.

    Another example is I have a lot of Buckethead. Well he was in a lot of bands, compilations, solo stuff and soundtracks. All of his tracks have the "Album Artist" field as Buckethead, while the "artist" field has something like Buckethead feat. Brain or Serg feat, Buckethead. This way I still run a smart playlist of my top 100 buckethead songs and I can pull from everything with him in it no matter what album or artist is featured with him.

    Now on your example if you know for a fact that they all should be set for one album the same, try selecting all the tracks at once and changing that 1 field by retyping it so that they all receive the same data. And if you want them listed as separate albums, then put the common name into the compilation field and check the compilation box.
  7. Defender2010 macrumors 68030


    Jun 6, 2010
    I have many many soundtracks with various artists, to stop them appearing the way yours all the tracks in the album and right click "get info". Then fill in/change the "album artist" to "various artists". The artist for each individual song stays the same, but it groups it into one album. Also make sure that the album is filled in correctly in this get info window. Leave "artist" blank as that will change all the artists in that album to the same one if you touch it...
  8. TJ61 macrumors 6502a

    Nov 16, 2011
    Select all, go into Get Info, and make a slight change to Album Name and save. You can go back in and change it back, but the important thing is to force iTunes to "reconsider" its classification of the album.

    Make sure compilation is checked, of course, and that no other entries exist under the "sort by" tab that would keep things separated.

    And, yes, you shouldn't have to change artists to "Various". *That's just a workaround for when you don't want to do the compilation album thing.

  9. MadGoat macrumors 65816


    Jul 30, 2007
    I just had the same problem this morning... what you need to do is change "Album Artist" not "Artist" to something like Various or Various Artists or blank it out.

    This brought my f'ed up list from 300 duplicate Jazz albums to 1 Jazz album
  10. peeaanuut macrumors 65816

    Sep 10, 2007
    Southern California
    there is also a setting on the phone, and I assume an iPod touch, that allows you to group by Album Artist. So if you are going with the album artist approach which does make the most sense, make sure that is on as well to get them to flow right.

Share This Page