How do I force Mac to use Ethernet connection when both WiFi and Ethernet are active?

Discussion in 'OS X Mavericks (10.9)' started by petrucci666, Oct 28, 2013.

  1. petrucci666 macrumors 6502a

    petrucci666

    Joined:
    Apr 30, 2009
    Location:
    Los Angeles, CA
    #1
    I live in a 2-story apartment, with the router downstairs.

    WiFi is weak upstairs but I have an ethernet cable running to my Cinema Display. When I connect my Mac to the display, both WiFi and Ethernet (through the Cinema Display) are connected but I think the Mac using the WiFi as its primary source, making it slow. How do I force it to use the Ethernet connection over WiFi without turning off WiFi?
     
  2. PsyOpWarlord macrumors 6502

    PsyOpWarlord

    Joined:
    Nov 11, 2010
    Location:
    Colorado Springs, CO
  3. petrucci666 thread starter macrumors 6502a

    petrucci666

    Joined:
    Apr 30, 2009
    Location:
    Los Angeles, CA
    #3
    Thanks a lot! This was exactly what I was looking for!
     
  4. TheCreech macrumors newbie

    TheCreech

    Joined:
    Dec 6, 2016
    #4
    that link is now disconnected - what was that answer?
     
  5. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #5
    https://web.archive.org/web/20150221165428/http://support.apple.com/kb/PH10971

    A newer version of the document is here: https://support.apple.com/kb/PH21578
    The summary is that it gives information on how to set network service order:

    • Choose Apple menu > System Preferences, then click Network.
    • Click the Action pop-up menu [​IMG], then choose Set Service Order.
    • Drag a service, such as Ethernet, to the top of the list.
    • Click OK, then click Apply to make the new settings active.
     
  6. marvin_h macrumors newbie

    marvin_h

    Joined:
    Aug 6, 2015
    #6
    Would be so cool if this worked. None of my macs, 2016 MacBook Pro and 2017 iMac honor this. The only way to workaround it is to turn WiFi off. Otherwise they refuse to use the Ethernet connection.
     
  7. Avenged110 macrumors 6502

    Avenged110

    Joined:
    Aug 2, 2010
    Location:
    Greatest Country on Earth
    #7
    Yea, I've noticed that. After prioritizing Ethernet, when I'm transferring files to my headless mini with both Wi-Fi and Ethernet connected, turning off Wi-Fi doubles the transfer speed. Never could figure out why.
     

Share This Page