Resolved How do I get back to lion after failed el capitan install

Discussion in 'macOS' started by Paul4, Oct 17, 2015.

  1. Paul4 macrumors newbie

    Joined:
    Oct 17, 2015
    #1
    Hi! I have a late 2011 MacBook Pro that had lion running on it, and thought to finally upgrade the OS. I tried various times to install el capitan, but it always got stuck in the end and shows me an error log, that installation could not finish. I have no understanding about what the log errors mean.

    So I had a time machine back up and reversed from there, but I made the mistake not including applications in the back up thinking it was saving space. Stupid of me, but it's already done. Now I get back to lion but have absolutely no programs so I can't open or do anything even if the files are there. I read some advice about just reinstalling the OS with recovery mode, but when I do that it starts downloading and installing el capitan again, which won't finish. So from where and how do I get the full lion with the original applications installed, or as I excluded the folder when making the back up, have I lost them? Of course I would be happy with any other working OS as well.

    What are my options, what can I do and how, to get my MBP working again, and restore my files from the time machine back up?
    I would be very grateful for any help! Thank you!
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    A word of advice:
    THE NEXT TIME you decide to try a system upgrade, DON'T DO IT "over" your existing OS installation without a fully-cloned and bootable backup close-at-hand.

    To understand why, look at the problems you are having now.

    In the future, I would suggest that you use an external drive and do an "experimental install" of the new OS there FIRST. You can then "migrate" from your existing/working internal drive. You can see what works and what doesn't. All without touching your internal.

    Some questions:
    Have you re-initialized the internal drive?
    Do you think your old applications may still be on it?
    Do you have a folder at the root level called "OLD System folder" (or a name similar to that)?

    Aside:
    It might be time to consider replacing the old internal drive with an SSD.
    You will be AMAZED at the performance increase.
     
  3. Riwam macrumors 6502a

    Riwam

    Joined:
    Jan 7, 2014
    Location:
    Basel, Switzerland
    #3
    ***********
    The question of Fishrrman is a good one.
    Have you written new data or modified the HD?
    Disk Warrior is a very good tool to find still existing data and it should be run from a DVD or a USB stick in order not to make changes to that problematic HD.
    I don't know if it can restore applications but it helped me to restore many files in an accidentally formated HD.
    You can find it in many "places" in the web, but of course all done NOT from the problem HD which might still have things you are looking for but from other computers.
    Good luck!
    Ed
     
  4. Paul4 thread starter macrumors newbie

    Joined:
    Oct 17, 2015
    #4
    Yeah, had to learn it the hard way. This was my first OS update (attempt) and thought I was safe with the back up I had. Somehow I thought the applications folder had only the ones I had installed afterwards, not the ones that come with the OS.

    Finally I rebooted again from the time machine back up I had (without any programs) and then I managed to do the internet recovery, yay! So nothing important lost, just have to install other programs again, but at least now I have the ones that came with the Lion :) Hope to be able to make El Capitan update some day, but now I think I'll wait for some updates before I dare to try again, and with a total back up!

    Thank you for your help!
     
  5. Riwam, Oct 18, 2015
    Last edited: Oct 18, 2015

    Riwam macrumors 6502a

    Riwam

    Joined:
    Jan 7, 2014
    Location:
    Basel, Switzerland
    #5
    ********
    If it consoles you a little bit, I tried today to upgrade from Yosemite to El Capitan.
    Following the advises, I made before a clone of the internal Yosemite drive in an external USB drive.
    For reasons unknown to me the upgraded El Capitan didn't let me shut down the computer or restart it.
    I tried to install once again El Capitan over the previous one but the bug with no shut down or restart remained.
    I therefore started from the back up, erased the internal drive and cloned back my Yosemite.
    By doing so I had again Yosemite in the internal drive but lost my recovery partition.:(
    For the time being I will wait with El Capitan, as you intend to do.
    Too much trouble for nothing...:oops:
     

Share This Page