How do I get my watch to pick up wifi?

Discussion in 'Apple Watch' started by michael31986, May 2, 2015.

  1. michael31986 macrumors 68030

    Joined:
    Jul 11, 2008
    #1
    I'm inside my house and I went upstairs away from the Bluetooth and for some reason the Apple Watch says it's Fareway from the Bluetooth which I understand, but why isn't it doing the functions it should allow via Wi-Fi such as calling texting using hey Siri. How do I get the phone to work with my Wifi at home.
     
  2. Swiss-G macrumors 6502a

    Swiss-G

    Joined:
    Jun 3, 2010
    Location:
    United Kingdom
    #2
    Disconnect you iPhone from your home network and then add it back again.
     
  3. ZMRoach macrumors regular

    ZMRoach

    Joined:
    Sep 4, 2007
    Location:
    Seattle
    #3
    Are you using 802.11ac at home by chance? I don't believe that Apple Watch supports this protocol and could explain the issue.

    Once I get my watch I'll probably play around with connectivity like this and be able to probably help more, but this was just the immediate concern I had when reading this.
     
  4. brandonfro macrumors newbie

    Joined:
    Aug 20, 2014
    Location:
    Charleston, SC
    #4
    This is a good point, however, I would guess that whatever router you're using also has 802.11b/g/n radios as well and should be able to handle "legacy" clients that don't support ac, like the Apple Watch.
     
  5. iamasmith macrumors regular

    iamasmith

    Joined:
    Apr 10, 2015
    Location:
    Cheshire, UK
    #5
    This could be an interesting topic with the watch inheriting WLAN settings from the phone. I just left a Sky contract where you had to register the MAC addresses of the devices that you wanted to use on their partner wifi connections - if the watch just inherits the connection settings and there is no way to register its MAC address on this kinds of service then any software that makes direct connection instead of proxy through the phone is going to suffer the 'nofi' problem.
     
  6. applepuree macrumors 6502

    applepuree

    Joined:
    Aug 15, 2014
    #6
    The watch uses ipv6 and the routing is all handled by the phone. The router doesn't even really see the watch, so there should be no need to register the mac address.

    I just checked on my router and there is no evidence of my wifes Apple Watch in the routing tables.
     
  7. ZMRoach macrumors regular

    ZMRoach

    Joined:
    Sep 4, 2007
    Location:
    Seattle
    #7
    Very true, but I have seen some people completely disable those radios in favor of using just ac. But yes, a simple fix is to just make sure that dual band is enabled for the legacy support.
     
  8. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #8
    So forgetting network on the phone and then reconnecting should work?
     
  9. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #9
    That's what people here say, but it hasn't worked for me on my AEBS (new model). I've got 2.4GHz and 5GHz showing the same SSID (a change I made in a vain effort to help the watch) and even after forgetting and re-joining the network several times, my watch is never able to connect. Maybe it's defective?
     
  10. BvizioN macrumors 68040

    BvizioN

    Joined:
    Mar 16, 2012
    Location:
    Manchester, UK
    #10
    Not sure how, but Apple watch seems to conect to known wifi (known by iPhone)

    I did a test this morning. Turned bluetooth off on the iPhone and did send a message to myself through Apple Watch. It came through, no problem. Then turned Airoplane Mode ON on the iPhone and did the same test. The message came through on the Apple Watch again. So it seems, even if the iPhone is OFF or not on you, as long as you are on the known wifi network you are still able to perform some basic stuff on the Apple Watch.
     
  11. ant1298 macrumors 6502

    ant1298

    Joined:
    Oct 17, 2011
    #11
    I found I had to reconnect the phone to the wifi for it to work. Just disconnect and reconnect, did the trick for two watches in my household.

    ----------

    I have a linksys AC router. Capable of 2.4/5GHz and legacy bands.
     
  12. ulinerg, May 3, 2015
    Last edited: May 3, 2015

    ulinerg macrumors member

    ulinerg

    Joined:
    Oct 21, 2014
    Location:
    Ottawa, Canada
    #12
    Just tried this morning to confirm that my watch works with Wi-Fi.
    My phone was connected to my 5GHz SIDD so I turned off Bluetooth and the watch lost it's connection and was not able to find my location in maps and the wech's Apple store couldn't connect.
    Then I switched the phone's Bluetooth back on to re-established the watch's connection, switched the phone to my 2.4GHz SIDD. This time when I turned off the phone's Bluetooth the watch gave me the disconnected icon but its internet connections, (map & Apple store) worked as advertised
    Pretty ��
     
  13. samo350 macrumors member

    Joined:
    Oct 20, 2012
    Location:
    Montpellier, FR
    #13
    I think no, for me I can see my watch on my router, it has it's own IP adresse ..., But I've noticed that the watch is not always connected, you can see it by turning off your iPhone (normaly siri would continue working...) and at this moment you can see your watch connected on your router
     
  14. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #14
    It learned my house wifi but not my bf's. Hmm strange.
     
  15. bothfly737 macrumors member

    Joined:
    Sep 25, 2014
    #15
    I posted this on another thread.
    I have named my AE's 2.4 and 5GHz networks the same(not sure if this is needed but it works). Forget the wifi network you are trying to join on your iPhone, then reconnect. If your watch is near your phone it will choose the BT connection, when you walk out of BT range it may take 30 secs to a minute for the watch to join the wifi network.
    To test this go into the watch and note the Mac address, then turn off BT on your phone. Scan your Wifi client list and you should see your watch appear. Use a land line to make a call to your phone and the watch should ring, same for texts and anything else.
    The problem is if you leave the BT on and walk around your house near your phone the watch keeps wanting to join to BT then back to the WiFi, hopefully there will be a SW update that if the phone is on a known wifi network then the watch will auto join as well and not keep switching back and forth.
     
  16. AN1 macrumors newbie

    Joined:
    Apr 28, 2015
    #16
    FYI, the remove and re-add song and dance fixed it for me. Seems like a bug, let's hope for a fix soon #
     
  17. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #17
    no 5ghz

    It won't connect to wifi that is using 5ghz, and you can tell I believe IF it is connected to wifi instead of to the phone via bluetooth but the little spinning dots in the UPPER RIGHT are of the screen. At least that is what I think they are for since they have only appeared for me when the BT on the phone was off.
     
  18. MoodyM macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #18
    Actually, there's a solution:

    1. Turn off the Watch
    2. Forget the 2.4Ghz and 5Ghz Wi-Fi connections on the iPhone
    3. Turn off Bluetooth on the iPhone
    3. Connect the iPhone to the 2.4Ghz network, and then turn on Bluetooth
    4. Turn on the Watch (this caused the watch to connect with the iPhone and connect to the 2.4Ghz network using the iPhone credentials)
    5. Turn off Bluetooth on the iPhone and then test that Siri still works on the Watch or send an iMessage, etc
    6. Turn Bluetooth back on on the iPhone
    7. Disconnect/forget the 2.4Ghz network on the iPhone and connect it to 5Ghz network
    8. Check again that with Bluetooth on iPhone turned off, Siri/iMessage/etc still works on watch and Watch MAC address appears in router attached devices list (it only appears when Bluetooth on iPhone switched off).

    The key thing seems to be to first connect the Watch with the iPhone when the iPhone is connected to the 2.4Ghz network, because the Watch does not connect at 5Ghz (only 802.11b/g/n 2.4GHz Wi-Fi) and will only connect to a network that it has learned from the iPhone. After that, the iPhone can be connected to the 5Ghz network.
     
  19. spiderman0616 macrumors 68030

    spiderman0616

    Joined:
    Aug 1, 2010
    #19
    I'm so glad someone posted this--mine wasn't working on wifi without the phone on. I just went into my wifi settings, forgot my network on my phone, rejoined it, and now the watch is working without the phone connection.

    Love it!
     
  20. amro, May 3, 2015
    Last edited: May 3, 2015

    amro macrumors 6502

    Joined:
    Jul 7, 2008
    #20
    Wow! Thanks a bunch. Did not realize my watch was not connected to WiFi. Your steps cleared it up. I even see it in my router distribution list. Never thought to look for it when I first set it up. Big thumbs up!

    Edit: Just noticed that when the watch is connected by Bluetooth to the iPhone, the router shows the watch as no longer connected to WiFi. As soon as I turn off Bluetooth on the iPhone, the watch shows an active WiFi connection.
     
  21. KenMacGilroy macrumors newbie

    Joined:
    Mar 20, 2016
    #21
    I chatted with Apple Watch tech support, and they said both Bluetooth and WiFi need to be on for the iPhone paired to the Apple Watch for the Watch to connect to WiFi. Look at this: https://support.apple.com/en-us/ht204562. I tested the "turn of bluetooth on the iPhone" many times and it only worked once. The best way to check if the watch is connected to WiFi is move your iPhone far away from the watch but when both are in WiFi range, and try to make a call or send an iMessage from the watch. If you have Airport Utility, or a network monitor on your Mac, you can check if the watch is connected to your WiFi.
     

Share This Page