How do I get OSX back?

Discussion in 'macOS' started by Coflash, Oct 10, 2013.

  1. Coflash macrumors newbie

    Joined:
    Jul 13, 2013
    #1
    Hello

    I have a 2013 MBA and OSX isn't installed. I tried getting Mavericks to work, and in my attempt I formatted the drive entirely.

    When I try to re-install Mountain Lion, it throws an error message about not being able to check

    I have a mountain Lion install .dmg file and when I copy that to a USB stick and attempt to boot from it, I get a circle with a strike through it

    It seems I need OSX to solve this problem, but the problem is I need OSX :/

    Any suggestions?
     
  2. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    Where did you get this computer? You should be able to take it to an Apple Store or the shop where you bought it and get them to install OS X on it, at the least.

    However, the computer has a firmware partition that you can boot to when the drive is completely erased. See the Apple Support document about Recovery Partition.

    Normally, the drive should have a recovery partition on it too, but if you wiped that, then it won't be there. It's pretty difficult to wipe the recovery partition -- it won't be done by a standard erase.

    If you have Mavericks on another disk (which you must have done in order to erase your internal drive), then you should still be able to use that, too.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    You can reinstall the OS through Internet Recovery. Hold command-option-r (all three at once) as you boot. Once the recovery screen comes up start Disk Utility and select the drive itself at the top and erase it as Mac OS Extended. Then quit Disk Util and click reinstall OS. This will take some time as the 4.7GB OS needs to DL over the Internet.
     
  4. Coflash thread starter macrumors newbie

    Joined:
    Jul 13, 2013
    #4
    Hello

    Thanks for the suggestions, but it was as simple as trying a different internet connection

    For some reason when I was at work, it would 'check' with Apple but it'd immediately throw the error

    At home it sort of 'thought' about it a bit more and then worked

    Thanks again
     

Share This Page