How do I get rid of a self-assigned IP?

Discussion in 'MacBook' started by Loudmind, Aug 18, 2010.

  1. Loudmind macrumors newbie

    Joined:
    Aug 18, 2010
    #1
    I've been trying for the last couple of days to get rid of a self-assigned IP address on my wife's white 13-inch MacBook (Model A1181, running Mac OS X 10.4.1). I've done everything from deleting files from the System Configuration folder to futzing around with keychains and changing all kinds of AirPort settings. But, as of now, still no luck - and no Internet connection.

    I'd really appreciate some advice and help in resolving this. Thanks for any help you can offer.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    You could manually set up the IP for your wife's MB in order to properly connect to the network you have.

    Take a look at System Preferences > Network > AirPort (if that is the device the MB does use to connect to your home network) >> Advanced > TCP/IP > Configure IPv4 > Manually.

    If you know more details, like settings and IP addresses, please post them. You can also attach screen shots to your posts if you want and use Preview's annotation tools to mask private information like network names.


    Taking screenshots in Mac OS X.

    Annotate non-PDF images in Preview

    [​IMG]
     
  3. Loudmind thread starter macrumors newbie

    Joined:
    Aug 18, 2010
    #3
    Thanks - I'd appreciate any help with manually configuring it. Tried, but not successful so far, so I went back to using DHCP.

    Her IP address is coming up as 169.254.209.195. Won't change if I try to renew it. Subnet mask is 255.255.0.0.

    My IP address (which works fine, MacBook Pro) is 192.168.1.102. Subnet 255.255.255.0. Router 192.168.1.254.

    Both connected through AirPort. Her Internet works fine when cabled in through Ethernet.

    Thanks again for your help.
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    You set Configure IPv4 to Manually and it reverted back?

    What about creating a new location for that AirPort situation and setting everything manually? Your wife's IP and Subnet Mask are not correct, if your IP and Subnet Mask are the working example to go on.

    Btw, is your wife's MB connected to the correct network? Have you taken a look at System Preferences > Network > AirPort >> Advanced > AirPort > Preferred Networks and seen any networks, she doesn't normally use? Is your home network on top of that list?

    If that still does not work, go to Macintosh HD / Library / Preferences / SystemConfiguration and delete the following:
    com.apple.airport.preferences.plist
    NetworkInterfaces.plist
    preferences.plist
    com.apple.nat.plist


    See if you can set up your network manually after that.
     
  5. Loudmind thread starter macrumors newbie

    Joined:
    Aug 18, 2010
    #5
    OK, thanks - one question: what IP address should I use for hers? If I use the same, won't there be a conflict?

    I tried manually configuring and deleting those files with no luck so far - although Network Diagnostics indicates I'm connected to the ISP (but not the Internet).

    Thanks again.
     
  6. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #6
    192.168.1.1 till 192.168.1.255, except 192.168.1.102 and 192.168.1.254.

    Did you make sure, you are connected to the same network? Did you take a look at Preferred Networks?
     
  7. Loudmind thread starter macrumors newbie

    Joined:
    Aug 18, 2010
    #7
    Hey there, yes, this is the only network in the list. I've assigned it IP 192.168.1.107, with the correct subnet and router, but no luck so far. In Network Diagnostics, ISP flickers from red to green and back to red, over and over.

    Am I missing a step?
     

Share This Page