How do I get rid of this error?

Discussion in 'macOS' started by one1, Feb 14, 2008.

  1. one1 macrumors 65816

    Joined:
    Jun 17, 2007
    Location:
    Chattanooga, TN
    #1
    I don't even have an epson printer so no need in having this trying to load. It just keeps constantly going... the log file is ten miles long on this error.



    Feb 14 18:32:57 MacBook com.apple.launchd[128] (com.epson.epw.agent[262]): Exited with exit code: 1
    Feb 14 18:32:57 MacBook com.apple.launchd[128] (com.epson.epw.agent): Throttling respawn: Will start in 10 seconds
    Feb 14 18:33:07 MacBook com.apple.launchd[128] (com.epson.epw.agent[263]): posix_spawnp("/Library/Printers/EPSON/InkjetPrinter/EPW/IJEPWAgent.app/Contents/MacOS/IJEPWAgent", ...): No such file or directory
     
  2. rccola70 macrumors regular

    Joined:
    Oct 28, 2004
    Location:
    California
  3. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #3
    This error is caused by an errant entry in the launchd configuration files. There's a free utility called Lingon that's useful for editing these - if you can track down the offending entry and remove it, you'll probably need to restart the computer for the change to take effect.
     
  4. jnichols959 macrumors newbie

    Joined:
    May 24, 2006
    #4
    look in /Library/LaunchAgents

    i found the offending launchd agent and removed it by doing the following in the Terminal (Utilities folder). the lines starting with $ are things i typed (don't include the "$") and the other lines are output i saw in the terminal:

    Code:
    $ launchctl list | grep epson
    -	1	com.epson.epw.agent
    
    then i used the label in the last column to remove it

    Code:
    $ launchctl remove com.epson.epw.agent
    
    this stopped the console errors. i also removed the file from /Library/LaunchAgents/com.epson.epw.agent.plist

    http://developer.apple.com/MacOsX/launchd.html has more info on launchd.
     
  5. davenoyb macrumors newbie

    Joined:
    May 31, 2010
    #5
    IJPEWAgent

    I have Snow Leopard 10.63 on my Macbook and have this same problem. I just got this popup now when I tried to Secure Empty Trash. Not only that I just lost my Back and Forward navigation buttons. But I'm a Mac newbie so this may be unrelated to the Epson problem. I have the Artisan 50 Epson printer. Still waitng for the rebate after almost 3 months. Damn! I can't navigate back and forth and it really is a big headache. I need help.
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    More info Dave...
    Your browser is _____

    You tried the solution proposed in the post above yours, and the result was _____
     
  7. getrfreakon macrumors newbie

    getrfreakon

    Joined:
    Nov 7, 2009
    Location:
    the Hell that is Tucson
    #7
    jnichols959, you just saved my bacon! I am trying to backtrack some behavior patterns with the Console, but all the info I needed was wiped out by the redundant repetiton of this stoopid 'feature' from Epson. Thanks for your contribution. To davenoyb who has (?) this issue: I would like to offer some kind of encouragement, but I am not really sure if I even understand the problem. What popup did you get? & Gregg2 gave you a good place to start.
    Mayhap you can come forth with more info & the wizardry can begin! It sure did work for me!

    (Props, guys.)

    Edit: I just posted my reply, and noticed this too-rich-to-ignore ad under my post:

    ads by Google
    Epson america
    The Official Home for Epson Products. Shop at the Source Today
    Epson.com
     
  8. ksmithtn macrumors newbie

    Joined:
    Mar 21, 2011
    #8
    Thanks, jnichols959!

    It fixed me up, too! No telling how long this has been going on. I'll never buy an Epson printer again.
     
  9. prosecutor macrumors newbie

    Joined:
    Nov 13, 2007
    #9
    Thanks

    This has bugged me for years, ever since I had the misfortune of trying an Epson printer.
     
  10. adrian75, May 27, 2016
    Last edited: May 30, 2016

    adrian75 macrumors newbie

    adrian75

    Joined:
    May 27, 2016
    Location:
    madrid
    #10
    same problem... in 2016 when installed el capitan!!! same solution, thx!

    edit: it comes back whenever i start the computer. there must be a way to get rid of it but i can't find it. any ideas?
     

Share This Page