How do I get weather in Notification Center ?

bbchick

macrumors newbie
Jun 2, 2010
29
0
Go into Settings>Privacy>Location Services (make sure it is on), scroll down to Weather and allow location access "Always".

Took me a while to figure it out.
 

mofunk

macrumors 68020
Aug 26, 2009
2,415
159
Americas
Open your phone - Swipe down for Notifications - Go to the bottom of the Screen to Edit button - Click on Edit button - Add apps.


Now if the Weather app isn't shown - go out of Notifications - Open Weather App and Yahoo Weather App. Set your locations. Go back to the first steps.
 

EzDoesItSC

macrumors member
Nov 20, 2012
62
7
Does this kill the battery when it's enabled all the time? It used on my old droid phone from years ago.
 

yaboyac29

macrumors 6502a
Sep 24, 2014
651
468
i use forecast+

widget is better than apple's and you don't need location services on for it
 

shook187

macrumors member
Sep 21, 2014
36
23
I'v done everything on this thread and i still don't see weather in the notification Center
 

roland.g

macrumors 604
Apr 11, 2005
6,713
1,799
I'v done everything on this thread and i still don't see weather in the notification Center
Go to Today view, not Notifications and hit Edit at the bottom, make sure it is in the included list.

Also remember there is Apple default weather, now powered by The Weather Channel instead of Yahoo, then there is Yahoo Weather, and The Weather Channel app, just to name three. Both the default weather will appear in Today view if you want and you can also add Yahoo Weather which does so with a picture by enabling access per above posts with location services then editing the Today view. The Weather Channel standalone app does not have a Today view widget.
 

wtrswoopes

macrumors newbie
Aug 8, 2011
12
5
I'v done everything on this thread and i still don't see weather in the notification Center
I was having the same issue as you. Did everything in this thread and no change. Rebooted my phone and magic....the weather is back.
 

EJ8

Suspended
Oct 13, 2010
645
324
I was having the same issue as you. Did everything in this thread and no change. Rebooted my phone and magic....the weather is back.

I'm going to confirm that I also have not been able to add the stock weather widget in 8.0.2. Not only did I know all of the above suggestions but I went through them again after reading this just to make sure I wasn't going crazy. Weather is not listed in the widget edit list. I added Weather Underground to replace the stock widget. But the OP is not misinformed or misguided. It isn't available for some people. Never a complainer but the list of issues is building like crazy. Things are effed up in Cupertino.
 

shook187

macrumors member
Sep 21, 2014
36
23
How do I get weather in Notification Center ?

Go to Today view, not Notifications and hit Edit at the bottom, make sure it is in the included list.



Also remember there is Apple default weather, now powered by The Weather Channel instead of Yahoo, then there is Yahoo Weather, and The Weather Channel app, just to name three. Both the default weather will appear in Today view if you want and you can also add Yahoo Weather which does so with a picture by enabling access per above posts with location services then editing the Today view. The Weather Channel standalone app does not have a Today view widget.


I was having the same issue as you. Did everything in this thread and no change. Rebooted my phone and magic....the weather is back.

Thanks guys, still a no go with the stock weather app but i got the Yahoo weather app working
 

Generik777

macrumors regular
Aug 21, 2010
124
4
To get the stock app working do this. First the obvious things like enable location. But the most important is to open the stock weather app. Swipe all the way to the left which is the location based weather area. Wait here until it loads the weather for your location. Now the weather should show up in the Notification Center.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.