how do I keep Finder from searching my external HD?

Discussion in 'macOS' started by firstyearprof, Jan 31, 2008.

  1. firstyearprof macrumors member

    Apr 16, 2007
    Hi all,

    Quick question from a mac neophyte. How do I keep the Finder from searching through my external HD? The behavior I'm trying to get rid of is this: I double click my hard drive (or go to save a file), and my computer hangs for several seconds while my external HD begins to whirl. Beachball. Finally, it all comes back on line with my external showing up to.

    I would like for Finder to not try to access the external unless I specifically ask it to. Any ideas? Thanks!!

  2. Dimwhit macrumors 68000


    Apr 10, 2007
    I have the same problem. Only it happens at stupid times, like during the Save dialog or when I right-click an icon in the dock.

    I asked around and couldn't come up with any way to prevent it.
  3. roland.g macrumors 603


    Apr 11, 2005
    One mile up and soaring
    Shouldn't do that unless you are accessing that drive through the finder or save dialog. Do you have Put Hard Disks to sleep when possible checked in the energy saver options. That will keep your external sleeping unless you specifically browse them.
  4. Luis macrumors 65816


    Jul 19, 2006
    Costa Rica
    Try putting the external HD under the "Privacy Tab" in Spotlight preferences.
  5. firstyearprof thread starter macrumors member

    Apr 16, 2007
    Hi all,

    My external HD was already set to not being searched under the "privacy" tab for spotlight. Also, my preferences say "put harddrives to sleep" under power options. Same behavior... other ideas?
  6. Amdahl macrumors 65816

    Jul 28, 2004
    I have seen this complaint elsewhere, probably on here. Maybe 10.5.2 will fix.
  7. richard.mac macrumors 603


    Feb 2, 2007
    51.50024, -0.12662
    the Finder spins up (wakes) an external drive if the disk platters have spun down (sleep) when a Finder window or Finder open/save window is opened. this is how the Finder works and i dont think there is a way to modify this behaviour.

    the only work around is to uncheck "Put hard disk(s) to sleep when possible" in the Energy Saver preferences. this prevents the disk platters of the external drive spinning down. overtime a hard drive whos disk platters are kept spinning will have a greater life span than one whos platters are spun down all the time.

Share This Page