how do I make safari use flash for youtube instead of html5?

Discussion in 'MacBook Air' started by Sangdushi, Oct 8, 2011.

  1. Sangdushi macrumors regular

    Sep 9, 2011
    I didn't join the html5 beta program. majority of the videos just loads in html5 and I have to double click and restore it to flash. how do I just make it flash all the time? htlm5 is super laggy for me. I have the click to flash plugin
  2. Sangdushi thread starter macrumors regular

    Sep 9, 2011
  3. bwhinnen macrumors 6502

    Apr 15, 2010
    San Diego
  4. blingies macrumors newbie

    Dec 25, 2009
    I think it is related to the clicktoflash plugin.
    When i was installing plugins and setting up my safari a few days ago, I noticed clicktoflash automatically renders youtube videos as html5. I personally want it to block all videos, unless instructed by me to load.

    This was the main reason why i switched to using google chrome, I personally do want to use safari as my main browser, as i love that bounce feature at the top and bottom of pages, but all videos autoplaying, that puts me off.

    i hadnt found a solution to using both clicktoflash (to get rid of flash and ads) AND not autoplaying youtube videos.. :(
  5. Sangdushi thread starter macrumors regular

    Sep 9, 2011
    not enrolled.
    I'll uninstall the clicktoflash plugin and see what happens.

    I tried google chrome. I find safari faster and I use the navigation page scrolling gesture a lot and it doesn't feel the same without the animation.
  6. CubeHacker macrumors 65816


    Apr 22, 2003
    If you have click to flash:

    Open any website, and right click anywhere on the page that doesn't have text or pictures on it. An option should appear to change click2flash settings. Under one of the tabs, you can change the default video player for flash video. The options are 1.) HTML5 2.) Quicktime 3.) Flash

    You want to set it to the last one

Share This Page