How do I make sure I haven't enabled root user? / Pokesav

Discussion in 'macOS' started by EnCroix, Nov 12, 2010.

  1. EnCroix, Nov 12, 2010
    Last edited: Nov 12, 2010

    EnCroix macrumors newbie

    Joined:
    Feb 6, 2010
    #1
    So, I was trying to enable a program, which failed long story short. I do not know enough about terminal to do anything without a guide, but I was trying something that had supposedly worked for someone before. They recommended I type in "sudo login root".

    First, have I ****ed anything up with this? Second, did I accidentally somehow enable root? I probably shouldn't have even bothered trying, as I am rather ill-informed when messing with terminal. I read somewhere that this would log me in as a root user, and then I heard someone say that it simply acts as a root user.

    I didn't go and enable it through preferences, of that much I'm positive.

    Thank you for helping someone that's really not great with terminal. I just want to make sure that I didn't activate root user.

    Second, if anyone has an extremely clear way of using sendpkm on a mac, that would be helpful. :/ It's what I was attempting to do, but now I just think I shouldn't bother. I know I need to use the sudo command, but I don't want to be a root user to access it.

    edit: I'm running Mac OS X 5.8
     
  2. NoNameBrand macrumors 6502

    Joined:
    Nov 17, 2005
    Location:
    Halifax, Canada
    #2
    'sudo' does whatever comes next as root, and root never needs to enter a user's password to login as another user, so that's the 'sudo login root'. 'sudo su' and 'sudo -s' do the same thing.

    As for 'enabling' root, that just means setting a password so that root can log in directly. If you didn't run 'passwd' when you were acting as root, you're fine (security is as good as your password). If I recall correctly. I last enabled root on my G3 iMac running 10.2 using NetInfo Manager, so it's been a while. I don't do it on my Ubuntu boxes either.
     
  3. EnCroix, Nov 12, 2010
    Last edited: Nov 12, 2010

    EnCroix thread starter macrumors newbie

    Joined:
    Feb 6, 2010
    #3
    I might have tried password after reading something- something like "sudo login password" or maybe I put in "sudo password root". >:

    is there any way to set it back to default, IE- there is no root password, and that it isn't enabled? I'd like to just make sure I didn't, because I really can't recall.
    Can I just run that again and set the password to "*"?

    I can't imagine anyone would guess my password, but if it was logged somewhere, I suppose I can never know.

    Edit: On the brightside, I got sendpkm to work on my mac. ~_~ I hope it wasn't because I enabled root, though...
     
  4. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #4
    You can use Directory Utility to disable the root account (or rather, access to it). If you're in Leopard, it's under /Applications/Utilities/. If you're in Snow Leopard, it's a bit more tucked away, in /System/Library/CoreServices/Directory Utility.app.

    Click the lock in the bottom left corner of the window, enter your admin password, then look at the Edit menu at the top of the screen. If you see "Enable Root User", then it's already disabled and you don't have to do anything (fairly likely as it stands). If you see "Disable Root User", like I did on mine when I just checked, then just select that and quit Directory Utility.

    jW
     
  5. EnCroix thread starter macrumors newbie

    Joined:
    Feb 6, 2010
    #5
    Oh, thank you very much, both of you. I checked and I don't have it enabled. I was simply worried since I'm not really familiar with the terminal. :/ Took me long enough to get sendpkm to work.
     

Share This Page