How do i patch TFT?

Discussion in 'Mac and PC Games' started by p005474n, May 1, 2010.

  1. p005474n macrumors newbie

    May 1, 2010
    I went out and bought Frozen Throne and Warcraft III. I also have a load of DotA maps, but i can't play them. My current version of TFT is 1.07. I have downloaded multiple patches but none of them work. Whenever I open them they can't mount a file to the disk or some crap. My real question is how do I patch a game on the mac. Please help!
  2. iMacDragon macrumors 68000


    Oct 18, 2008
    might be easier to register the cdkeys on and download installers from there?
  3. Sambo110 macrumors 68000

    Mar 12, 2007
    Just click on in the main menu and it will automatically update it...
  4. p005474n thread starter macrumors newbie

    May 1, 2010
    Tried that aswell but it won't connect. I'm pretty sure my internets way too slow for online gaming. I only use it for work.

    Edit: It says that I can't download a file because my hardrive is full. I checked it and i have 92.66 GB free.
  5. macfanboy macrumors 6502a

    Jun 5, 2007
    you have to be an administrator on the computer.
  6. p005474n thread starter macrumors newbie

    May 1, 2010
    I am. Another curious thing happened. I tried to make a single-player profile. When I clicked 'create' it said that there wasn't enough file space, yet it made the profile. Now I'm pretty sure that means that there's something majorly wrong.
  7. Joneswilliamsc macrumors newbie

    May 4, 2010
    Well I have just read your post I having no how can we do it on Mac. But I have download it on my Window. It works on Windows properly but not I also want to know how can we do it on mac because one of my friend having mac and he is playing well on it but I don't know how he has done it.
  8. Slux macrumors member


    Apr 27, 2010
    Are you certain that you are logged in with an Administrator account? I used to get that exact symptom when running TFT using my daughter's (non-admin) account.

    Regardless, coincidentally I just patched up my TFT last night. I downloaded the full patch installer from the support web page and ran it from the Warcraft III folder and it patched with no issues.

    On a different but related note, does anyone else get very long delays after clicking "Battle Net" on the main menu? It still eventually connects but the delay seems to be well over a minute.
  9. p005474n thread starter macrumors newbie

    May 1, 2010
    Hey guys, just letting you know, I fixed it! Figured out what was wrong. I changed my account to administrator a long time ago, but it didn't work. So I tried using the original account (original admin) and it worked. Weird, but I don't really care.

    BTW yes, I got massive delays from Battle net. Probably just my internet though...

Share This Page