How do I Port Forward Transmission with Apple Extreme Base Station?

Discussion in 'Mac Basics and Help' started by JWiss, May 18, 2009.

  1. JWiss macrumors newbie

    Joined:
    Jul 24, 2008
    #1
    Hi guys,

    It was drawn to my attention recently by a friend that I may not be getting the speeds I should from Transmission due to my lack of port forwarding. I just want to make it clear that I know nearly nothing about setting up/configuring routers, ports, upnp, static ip, or whatever other jargon is associated with this stuff. Quite frankly, most things to do with routers terrify me.

    In the preferences for Transmission it says that my port is closed. In case any of this is relevant I'm using a 2008 model 20" iMac connected wirelessly to an Apple Extreme Base Station, which in turn is connected to a D-Link 502T modem.

    I've already gone to portforward.com but everything I try seems to not work and confuse me. Every other forum post I've read about this topic has lots of jargon I don't understand, so if it is at all possible I would like somebody to explain how to do this to me as if they were teaching their grandfather how to use a computer for the first time!

    Any help would be greatly appreciated!
     
  2. CBell macrumors regular

    Joined:
    Jan 1, 2008
    #2
    I'll post this here since it's related, and hopefully somebody can answer us both.

    I am getting extreamly slow speed with Transmission. I have the ports forwarded fine, they are open, but the speeds I'm getting are never higher than 10 or 15 k/s. I also am not able to do anything else that requires a connection when I am using Transmission (like surfing the internet, or playing a multiplayer game, or even using my 360 to connect to Live or play movies on my network). WTF? Help.
     
  3. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #3
    I have NAT (NAT and UPnP are used with different routers, and are supposed to automatically open ports when that protocol is used) enabled on my Airport, which Transmission uses, and while my G4 fails to utilize the feature, my new MBP does so just fine as the port is always open.

    On the G4 I need to change it every now and then by opening up the Airport Utility app in the Applications/Utilities folder, clicking on the Advanced button at the top of the window, and then the Port Mapping tab.

    Then click the plus sign to add a new port, type in the port for transmission into both fields (51842 or whatever it is from Transmissions prefs), and then type in the last 3 digits of your Macs address, which can be found by going into the System Preferences and into Network. Your IP should appear at the bottom of the window. (the first sequence of numbers is the same, the last numbers in the IP are what is assigned to each device from the airport).

    If the port becomes closed later on, check your Network Prefs to see if the address has changed, and then head into the Airport's Port Mapping setting and modifying your previous data with the changed digits. This can happen after a restart, or shutdown, if other devices are connected/disconnected to the network that were assigned IP's ahead of that particular machine.


    Once done, apply the settings, which may restart the router, then after a minute or two, head into Transmission to see if the port is opened properly.

    If it is, and you aren't getting proper speeds, it could be a number of things including slow or not enough seeds (it's random to get my full speed of 150k/s, could have 5 seeders and get my full download speed, or could have 50 seeders and only get a portion), or your ISP may be blocking BT packets and slowing them down.

    If you want to test, check out some popular torrent (like a new *nix distro) that has hundreds of active seeders/leechers and see if you can get your full download speed.
     

Share This Page