How do I prevent Mission Control switching to the next desktop...

Discussion in 'OS X Mountain Lion (10.8)' started by Dolorian, Jun 26, 2012.

  1. Dolorian macrumors 65816

    Dolorian

    Joined:
    Apr 25, 2007
    #1
    When I hit Command+h to hide an application?

    Say I have the following desktops:

    Space 1 : Chrome
    Space 2 : Sparrow

    While using Chrome say I want to look for something in the desktop, so I hit "Command+H" to hide the app. But what happens is that mission control hides Chrome and then takes me to the next Space with Sparrow in it.

    It also happens if, for example, I am in the desktop and I open System Preferences. When I close the System Preferences window, it takes me to the next Space with Sparrow in it.

    What gives? It is a really annoying behavior.
     
  2. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
  3. Nero Wolfe macrumors regular

    Nero Wolfe

    Joined:
    Oct 28, 2007
    Location:
    Atlanta, GA
    #3
    When you hide or quit an application OS X returns focus to the last application you were using. I don't know a way to prevent that behavior, but unchecking this box in Mission Control preferences will stop it from switching spaces on you.

    [​IMG]
     
  4. Dolorian thread starter macrumors 65816

    Dolorian

    Joined:
    Apr 25, 2007
    #4
    Thanks! That prevents it from switching to the next desktop. :)

    It is still kind of broken tho, because now when i switch with Command+Tab from one application to another it stays on the same desktop. Oh well.
     

Share This Page