How do I reinstall quicktime? Or, how do I fix Quicktime's safari plugin settings?

Discussion in 'Mac Basics and Help' started by motulist, Oct 20, 2007.

  1. motulist macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #1
    I've been using OS X for at least 4 years, on several different Macs, and this is the first time I've EVER needed to reinstall a program, so I have no idea how to do it.

    Everything was working just fine, then a few weeks ago safari stopped showing the video window for movies it tries to play within a safari page. It shows the movie's time slider / volume bar, but no video window. (It's not that the video window is empty, it's that there's no video window showing up at all, meaning the movie's time slider bar is showing up in the middle of the box area where the movie is supposed to show up, not at the bottom the way you would see if it tried to play the movie but didn't have the correct codec installed) Then if I save the movie as source and open it up in the quicktime player, the video plays perfectly.

    This happens even on the movies that are embedded in Apple's webpages. My quicktime is up to date, quicktime player 7.2, and I'm on OS 10.3.9.

    So if anyone has any ideas how to fix the problem, that'd be great.
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    Try redownloading it from here.

    You may need to use Pacifist to open the installer file to reinstall it though its worth trying without first.
     
  3. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #3
    reinstall QuickTime Plugin.plugin and QuickTime Plugin.webplugin from the quicktime installer package using pacifist. these are the plugins that play embedded quicktime movies in safari.
    if this doesn't work just try clicking the use defaults button in the MIME settings in quicktime in system preferences.
     

Share This Page