How do I remove a shared device from the finder sidebar?

Discussion in 'macOS' started by Dimwhit, Mar 6, 2009.

  1. Dimwhit macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #1
    I've googled and search here, and I just can't find the answer to this.

    I renamed one of my computers at home. Now both instances of it show up in the Shared section of the finder sidebar and I can't remove the old one. When I do a Get Info, it shows as a PC Server, but I can't actually access anything on it. Is there any way to keep this from showing up?
     
  2. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #2
    There is a command to hide drives in the finder. I don't have it handy, but maybe that would also work for the shared. Search the forum for hide drives. It's a series of terminal commands that does it. I used it to hide windows drives but they remain accessible in programs like pathfinder and forklift for instance.
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  4. Dimwhit thread starter macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #4
    Nope, neither way works. Thanks for the suggestions, though.
     
  5. paultong macrumors newbie

    Joined:
    Apr 16, 2009
    #5
    goto side bar and view finder preferences.
    uncheck show bonjour computers.
     
  6. macintoshxiii macrumors regular

    macintoshxiii

    Joined:
    May 15, 2006
    #6
    Hi dude, unfortunately that doesn't work! My old name of my mac is still visible along with my new mac name! The only difference is, you can only access to the current name while the other has no contents at all. And also not forgetting that I'm also seeing that Mac123456a7890 PC icon too! Does anyone knows exactly how to handle such issue? Thanks alot man! Gosh...
     
  7. hollerz macrumors 6502a

    hollerz

    Joined:
    Sep 13, 2006
    Location:
    Durham, UK
    #7
    Sorry if this sounds stupid, but have you tried logging off and on? Same thing happened to me a while ago with a PC, logging out and in removed the old one.
     
  8. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #8
    If you don't like logging off you can restart Finder by holding down the option key and rightclicking on the Finder icon in the dock. Select relaunch and it will restart Finder. You could also do this in the "force quit" window when you press command-option-esc. If you love the terminal you can issue the command "killall Finder".
     
  9. macintoshxiii macrumors regular

    macintoshxiii

    Joined:
    May 15, 2006
    #9
    All right... why didn't I thought of that? Of course that works! But the other problem is... how to get rid of the other PC icon which appear as a server? Or is there anyway I can get rid the PC icon to a Mac icon? :rolleyes:
     
  10. furnaceml macrumors newbie

    Joined:
    Jun 6, 2011
    #10
    There is an outside chance you may have enabled that computer to automatically log on when you start up. Go to system preferences and hit Accounts. Click on your account and unlock it if necessary. If the offending server is listed highlight it and click the minus sign at the bottom and it will never return.
     
  11. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    That doesn't work. The accounts in System Preferences refers to login accounts on that Mac. It does not refer to drives or servers or other computers. Another thread resurrection by a newbie posting incorrect information.
     
  12. ScandaLeX macrumors newbie

    Joined:
    Aug 15, 2009
    #12
    Thanks so much. This solved my problem although I know for a fact I hadnt enabled guest access. Seems to have magically changed on it's own after a system update within the last few days and I just noticed it.

    Again Thanks!!
     
  13. jmooch82 macrumors newbie

    Joined:
    Jul 31, 2011
    Location:
    post falls idaho
    #13
    yeah i know i am posting to a older post

    ok i have lion like the last poster and here is how i fixed my sharing problem. i went in system preferences to users. from there i made sure it was unlocked to make changes. i then clicked guest which had on. i then unchecked the bottom box allowing computers to connect to shared folders. then it went away
     
  14. estacionsj macrumors newbie

    Joined:
    Apr 28, 2013
    #14

    Did u every figure out how to delete it, Im having the same problem.
    Thanks for any info u may have
     
  15. Atchoo macrumors newbie

    Atchoo

    Joined:
    Jul 19, 2017
    #15
    I know this thread is very old, but here's what always works for me (currently on High Sierra):

    Code:
    sudo killall -HUP mDNSResponder;
    1. Open Network Properties - Advanced
    2. Click the DNS tab and replace your router's DNS with 8.8.8.8 (Google's public DNS server)
    3. Click the WINS tab.
      • If there is no entries there, add your router's IP. (Alternatively, remove your router's IP address, and add your Mac's local IP) - the whole point with this is to force the network configuration to update, so the old "ghost" network shares disappears.
    4. Click OK and "use the changes".
    Code:
    sudo killall Finder;
    Reboot.
     

Share This Page