How do I reset Safari on the iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by g-boac, Feb 22, 2008.

  1. g-boac macrumors 6502

    Oct 7, 2007
    Hotmail has a problem with Safari on both the Mac and the iPhone where if you don't specifically "sign out" after using it, you can't sign back in. The fix on a Mac is erasing all cookies and history. I tried doing this on the iPhone, but no luck -- when I go to log in, the page simply loops endlessly, and then puts me back to the sign in page.

    I know that something is missing, because after going to /Settings/Safari/Clear History, Clear Cookies, Clear Cache, when I run iPhone Safari and go to the Hotmail page, my user name is still in the box. . .so obviously, something on Safari still is not resetting.

    How do I get Safari to COMPLETELY reset??

  2. mr.stinki macrumors 6502

    Jan 25, 2008
    Force Quit it...

    On an iphone, you can force quit apps, like on a mac. When an app freezes, press and hold the home button for about 6 seconds. You should see the screen go dark, and the menu bar (one on the top) shrink into the middle.
  3. atarin macrumors regular

    Sep 10, 2007
    If "force quitting" Safari doesn't work, try powering the iPhone off and then back on. That might work.
  4. Chilli71 Guest

    Force quitting, not with >= iOS4


    Pressing home Button for some seconds is now starting voice controll.
    I did not find a possibility to disable voice controll.

    My safary did completely hang (emptying cache and cookies did change nothing).
    But after powering off (completely) and on, luckily the content of safary was erased and it started with a blank page and is working again.

    Unfortunately I have the feeling that this kind of crash will not show up in Apples statistc though it was a very bad one.

  5. iceterminal macrumors 68000


    May 25, 2008
    Dallas Tx.
    Try to quit the app first. Go into Task Switching (double click home button) then find Safari icon. Hold down on the app icon until is starts shaking. Click on the X in the top left. Then hit home button and try Safari again.

    If that doesn't work you can also try.
    Settings -> Safari -> and scroll down to clear out settings, database, etc.

Share This Page