How do I return to 0º when I accidentally rotate with gestures in Photoshop

danielmedhurst

macrumors newbie
Original poster
Sep 29, 2011
3
1
London
Hello, I wonder if anyone can help. I have recently upgraded to the new Lion (something which I am slightly regretting now) and when I use photoshop I keep accidentally rotating the image using gestures.

It is useful occasionally but most of the time its just irritating. Is there something I can do to get it to snap back to 0º quickly? At the moment I have to try and manually rotate it to 0º with the gesture, which seems next to impossible to get it perfect.

Has anyone had any luck with this?

Many thanks,
Daniel
 

danielmedhurst

macrumors newbie
Original poster
Sep 29, 2011
3
1
London
I take it you've tried Edit > Undo?
Thanks Jimmy, I've been using Photoshop for years, I know my way around that. Its just this new gestures function that is confusing me. Surely there must be a quick key command to get it to snap back to zero.

I thought if you held alt or something it might rotate in 45º increments, allowing you to rotate back to 0º easily, but no. Any other suggestions?

Thanks.
 

Jolly Jimmy

macrumors 65816
Dec 13, 2007
1,357
3
Sorry, you just never know sometimes :rolleyes:

It seems like a major oversight to me for cmd-z not to work.
 

danielmedhurst

macrumors newbie
Original poster
Sep 29, 2011
3
1
London
Have you tried holding down Shift and then rotating it? That's the button to press most of the time when rotating.
Yeah that doesn't work unfortunately. There must be a way of doing it?
Apple really seam to be slipping otherwise.

This is the first OS I've upgraded to where I have been really disappointed by it. My mac actually slowed down after upgrading to Lion (and it was only 4 weeks old at that point). Plus it still seems to be full of bugs and while I'm ranting whats with the faux calendar look for iCal. That just looks like something Microsoft would do.
 
  • Like
Reactions: 0989382

Peter Mead

macrumors newbie
Oct 23, 2012
1
1
Great - It always seemed like a weird issue, and tried every variation on the 'shift / alt / cmd / ctrl' radar and got nothing.

'ESCAPE' works brilliantly - in fact it's gonna encourage me to needlessly rotate the screen in PS whenever I get the chance!

Thanks el Maco community.
 
  • Like
Reactions: ClawKing

etayyab

macrumors newbie
Jul 12, 2014
1
0
Press the r key to use the rotate tool, on the top tab click hit reset or change the degree to 0.
 

erikafranzi

macrumors newbie
Mar 17, 2016
1
0
It's nothing to do with Apple or Lion. It's a Photoshop thing.

Rotating with gestures (in photoshop) is the same as holding the R key and rotating with the mouse.

When you hold the R key a little tool bar appears at the top. Click "Reset View" there.
THANK YOU!!
 

YurmaSter

macrumors newbie
Dec 2, 2016
1
0
It's nothing to do with Apple or Lion. It's a Photoshop thing.

Rotating with gestures (in photoshop) is the same as holding the R key and rotating with the mouse.

When you hold the R key a little tool bar appears at the top. Click "Reset View" there.
I just got back into Photoshop and I had the same issue on Photoshop for Windows. Holding the "R" key and rotating with mouse works! Thank you!
 

ullysses31

macrumors newbie
Feb 2, 2017
1
0
It's nothing to do with Apple or Lion. It's a Photoshop thing.

Rotating with gestures (in photoshop) is the same as holding the R key and rotating with the mouse.

When you hold the R key a little tool bar appears at the top. Click "Reset View" there.
This works Great! - Thanks
 

toma932

macrumors newbie
Feb 14, 2017
1
0
within photoshop just press R and the Rotate View tool comes on then set the rotation to 0 in the top left
 

potionsmaster

macrumors newbie
Jan 3, 2018
1
0
It's nothing to do with Apple or Lion. It's a Photoshop thing.

Rotating with gestures (in photoshop) is the same as holding the R key and rotating with the mouse.

When you hold the R key a little tool bar appears at the top. Click "Reset View" there.
Thank you!
 

baryon

macrumors 68040
Oct 3, 2009
3,530
1,517
doesn't work for me o_O
[doublepost=1528907450][/doublepost]syke! it does ;)
anyone know how to disable the canvas rotation altogether?
You can disable the various shortcuts. In keyboard shortcuts, delete the shortcut for the Rotation tool ("R" by default). If you have a laptop and you want to stop rotating the canvas with the trackpad gesture, you can disable that somewhere in Preferences. After that I doubt you can accidentally rotate the canvas.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.