How do I save the state?

Discussion in 'OS X Yosemite (10.10)' started by Enoch07, Mar 13, 2015.

  1. Enoch07, Mar 13, 2015
    Last edited: Mar 13, 2015

    Enoch07 macrumors member

    Joined:
    Feb 7, 2015
    #1
    I have a MacBook Pro running OS X Yosemite. %95 of the time when I boot the laptop, my applications don't work. The only way they work is if I'm in safe boot. But right now at this moment everything works and I'm not in safe boot. I want to keep it this way. And I know if I were to restart this computer, it would go back to broken applications. Is there a way I can save the state os the OS/laptop?
    Please reply and thanks in advance!
     
  2. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #2
    Is this problem happening in other user accounts? Create a new user, reboot and try the applications from the new user.

    Another thing to try, repair permissions in Disk Utility and reboot. See if that helps.

    Finally, when the other 2 things don't work, boot to the recovery partition and re-install OS X: https://support.apple.com/kb/PH13871?locale=en_US. Those instructions are the same for Yosemite. Nothing will be deleted just re-installed.
     
  3. Enoch07 thread starter macrumors member

    Joined:
    Feb 7, 2015
    #3
    I already tried these. Nothing worked.
     
  4. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #4
    Just to clarify you tried all 3 of my suggestions, repair permissions, new user and re-install from recovery partition?

    Boot into safe mode and see if the issue happens. If it does not then the problem you are having maybe be related to some third party application or driver you are using and will need to be removed.
     
  5. Enoch07 thread starter macrumors member

    Joined:
    Feb 7, 2015
    #5
    The problem does not happen in safe boot. How do I find this application or driver and fix or get rid of it?
     
  6. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #6
    I would suggest going through everything 3rd party you have installed and try uninstalling them one at a time until your problem does not happen any longer. Do you have any virus scan software installed?
     
  7. Enoch07 thread starter macrumors member

    Joined:
    Feb 7, 2015
    #7
    I erased my hard drive when I reinstalled the os. Immediately after the reinstall, I tested tested Photo Booth. The problem was not solved even when I erased EVERYTHING so I don't see how uninstalling programs would work. The only 3rd party programs I have at the moment are audacity and google chrome. Both of which don't work properly.
    I don't have virus software installed. What do you recommend I get?
     
  8. DeltaMac, Mar 15, 2015
    Last edited: Mar 15, 2015

    DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    It can help if you can explain with a little more detail - more than "apps don't work properly"...

    Do you have the same problem with ALL apps?
    Does that same problem happen EVERY time? That is, always the same error, or the same app that crashes, etc ?

    Does nothing happen when you try to launch an app (nothing happens, and you don't see any result when you double-click on an app)?
    Or, the app launches, but immediately quits (and you see a window telling you that the app unexpectedly quit, or some other error message)?
    Or, the app launches, and looks like it is working, yet you can't get anything about the app to function?
    Or, your Mac just freezes (no mouse movement, etc)

    Finally - it sounds like you can - sometimes - get everything working. What trick do you need to get everything to work, at least for a short time? (Shut down completely, or do a normal restart, start up first in safe boot, then restart normally?)

    Is this still your 2010 MBPro, that has multiple problems?
    Exactly how much RAM is installed?
    Try reseating your RAM.

    Another idea to think about - your hard drive may be on the edge of failure.
     
  9. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #9
    Don't install any virus scanning software. That will not solve your problem. Macs don't need virus scanning software. You have something else going wrong. Like DeltaMac indicated your hard drive could be the issue. Do you have a external hard drive you can use to try a test? Create a partiton on a external hard drive, install Yosemite and boot to the external hard drive install. Just a thought.
     

Share This Page