How do I secure Airport with WPA

Discussion in 'Mac Basics and Help' started by Jeffifer714, Jun 17, 2012.

  1. Jeffifer714 macrumors newbie

    Joined:
    Jun 17, 2012
    #1
    I've not used the Airport on my iMac (OS 10.6.8), but I just got a Kindle Fire and want to be able to use the wireless now.

    I can turn on Airport, but I cannot find a way to password protect it. I've looked under networking and can select Airport to turn it on and off, but not configure with security/password/WPA.

    Under security ~ nothing that I can find.

    Under Sharing I can select Internet Sharing but the tight panel is all grayed out and even though Airport is there (is turned on) and has a check mark I cannot do anything with it. The AirPort Options button underneath it is grayed out too? The pane is not locked and I can make other changes, just nothing helpful for this.

    Thanks for help. I've search Google and the few thread that seem to relate all are dead links. How could something this useful and important be basically blown off in the iMac manuals that I can find. I don't get it.

    Airport Utility says it cannot detect it, btw, even though AirPort is up and running (checked it with the Kindle)


    Jennifer
     
  2. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #2
    Have you looked in System Preferences>Network>Airport. Click advanced. Double click the Airport entry. The security options are there, just checked.
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    Are you creating a wireless access point with your Mac or are you setting up an Airport Base Station?
     
  4. Jeffifer714 thread starter macrumors newbie

    Joined:
    Jun 17, 2012
    #4
    Setting up Airport on iMac for secure use with Kindle

    Thanks for the replies. Under Network< Airport< Advanced I was able to set a Network named what shows up as the default (my name's iMac). I was able to select Security and tried WPA personal and WEP password and both make no difference. When I boot the kindle and look under Wi-Fi the name is there and the kindle connects to the internet, but no password is required and the kindle reports mine as open.

    I have applied the changes in both cases (WPA and WEP) and rebooted the iMac and kindle and the WiFi still shows up as an open network?


    Also, I hate that my name shows up as the default network name when Airport is on. How can I change that so it is something else?

    Thanks for the help!

    Jennifer
     
  5. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #5
    OK. Try this. Now go to your sharing preferences and even though Internet Sharing is grayed out, highlight it. You should get some options on the right side. Put a check mark in Airport. and then choose the Airport Options button. Enter your security options. Hope this helps.
     
  6. Jeffifer714 thread starter macrumors newbie

    Joined:
    Jun 17, 2012
    #6
    Sharing Options

    Thanks Knoodles.

    I can check and uncheck Internet Sharing Service box, but it does not ungray the options on the right side. Nor does it affect the Airport Options button below the right side box (To computers using: FireWire, Ethernet, Airport - and this is checked).

    It is confusing to me why the iMac is now supposed to apply password security and yet it does not and I have an open network for internet sharing.

    Thanks,
    Jennifer

    ----------

    Thanks for any suggestions as well.

    As part of this kerfuffle I definitely want to change the name that is out there I don't want my first and last name published like that. I know it took it as a default of my personal info. Not good.

    ----------

    Thanks for any suggestions.

    I also want to get the default name (my first and last) off the network wifi list. I know it pulled it from my personal info on this iMac. Bad news.
     
  7. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #7
    Sorry I missed all that info in your op. And the padlock is unlocked? Can you change the Share Your Connection Through from Airport to Ethernet? If someone can get your options active instead of grayed out then that is where you change the network name.
     
  8. Jeffifer714 thread starter macrumors newbie

    Joined:
    Jun 17, 2012
    #8
    Too much sucess

    I now have the WPA Personal up and apparently working because it will no longer allow the kindle to connect even though I am using the correct name and password.

    ----------

    So, when I was able to get the WPA running I cannot connect at all. I reset to WEP and give it a password and it lists the wifi as open and does not require the password to connect on the kindle.

    And nope ~ I cannot get the grayed out areas to change and I cannot find how to switch it to internet either. It does not appear to give that option.

    I was having a nice relaxing day.
     
  9. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
  10. Jeffifer714 thread starter macrumors newbie

    Joined:
    Jun 17, 2012
    #10
    It's a miracle!

    I turned off internet sharing. Then Ethernet share to Airport and Airport options were no longer grayed out (OK not really a miracle ~ but seriously not obvious at first).

    I opened Airport Options and renamed the network, selected WEP and did the low bit encrypt with a five letter password.

    Kindle saw new name, not old, required password and was accepted.


    And Knoodles ~ thanks for hanging in there to help. I am sure other people will come to this forum looking to resolve the same issue.

    So, turn off airport (easy), update Sharing with Internet Sharing unchecked, select Airport options, update name and password protections, save. NOW turn airport back on.

    I think that before I could not get it to work because AirPort was ON when I was unchecking Internet Sharing.
     
  11. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #11
    Glad to hear that you got it sorted. I've found that most of the time the simplest solution is the correct one.
     

Share This Page