How do I set Pages as default for opening .docx and .doc files?

Discussion in 'Mac Basics and Help' started by JWiss, Jul 24, 2008.

  1. JWiss macrumors newbie

    Joined:
    Jul 24, 2008
    #1
    Hey everyone,

    I just got my new iMac 20" last week and iWork '08 with it. I just wanted to know how to set Pages as the default for opening all .docx (MS Word 2007) and .doc (MS Word 2003) files. At the moment TextEdit is the default and whilst I can change the default for individual files, I haven't figured out how to set it for every file.

    Any help would be greatly appreciated.
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #2
    In finder find a .doc (or.docx) file
    Highlight File, Right Click, Get Info (or press Apple+I)
    Open With, Pages
    Press Change All
     
  3. JWiss thread starter macrumors newbie

    Joined:
    Jul 24, 2008
  4. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #4
    So easy on a Mac isnt' it?

    On Windows you'd have to open an explorer Window, Press tools, Then Folder Options, then the File Types Tab, then you have to scroll through a long list of file types and find the one you want, then you have to select the program you want to open that file type with...and it may not even work when it's all said and done if InDesign has anything to say about it!

    One more simple reason why I love OS X.
     
  5. soccersquirt82 macrumors 6502

    Joined:
    Mar 11, 2008
    #5
    If you want to do that with all documents and not right click every new or downloaded document, download Default Apps to say all .doc (or whatever other file) open with Pages (or whatever other app).
     
  6. ditzy macrumors 68000

    ditzy

    Joined:
    Sep 28, 2007
    #6
    I know this is an old thread, but wanted to thank you for this. I've been trying to figure this out for ages. Thanks
     
  7. zlguocius macrumors newbie

    Joined:
    Mar 24, 2007
    Location:
    Earth
    #7
    What if "Change All" is greyed out (as it is for me)?
     
  8. pdjudd macrumors 601

    Joined:
    Jun 19, 2007
    Location:
    Plymouth, MN
    #8
    Make sure the file is one where you have full permissions to.
     

Share This Page