How do I stop Apple Remote from controlling my iMac?

Discussion in 'Windows, Linux & Others on the Mac' started by MaskedCarrot, Nov 15, 2012.

  1. MaskedCarrot macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Northern VA
    #1
    I have an early '09 iMac and have an issue I can't figure out how to fix in regards to the Apple remote. I barely use OSX on it, and am mainly in Windows 7, so this is a Windows issue.

    I have an Apple TV 2 in the same room as my iMac, and every time I use the remote to control the Apple TV, it also at the same time does stuff on my mac, like volume control, every time I hit Menu on the remote, iTunes come up on the computer.

    What do I need to do to prevent the Apple remote from controlling the computer? I've tried deactivating bluetooth in windows, and even went into Device Manager and disabled the bluetooth, but it still controls the computer. I can't figure out what I need to delete or deactivate in windows to make it stop.

    Any help would be much appreciated.
     
  2. MaskedCarrot thread starter macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Northern VA
    #3
    Thanks for the reply, but as I said in my other post, this is in regards to the remote control effecting Windows 7 on my iMac, not in OSX.

    I've googled it and every article I've seen tells how to do it in OSX, but none that I find tell how to disable in within Windows.

    ----------

    Ok I figured it out. I was assuming the remote was using Bluetooth, that is why deactivating that did nothing.

    After looking through all the OSX how to disable guides, I see that it is using Infrared. (Which doesn't make sense how that worked being as I thought IR had to be line of sight and pointing it at my Apple TV is the opposite direction from my mac).

    Anyway, I went into device manager, and under "Human Interface Devices", I disabled the "Apple IR Receiver" and presto it worked!! No more remote control messing with the computer.
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    You can also go to Control Panel->Boot Camp. There will be a tab for Remote. Click the check mark next to "Disable remote control infrared receiver"
     

Share This Page