How do I stop character popup when typing?

Discussion in 'OS X Mavericks (10.9)' started by robgendreau, Dec 10, 2013.

  1. robgendreau, Dec 10, 2013
    Last edited: Dec 10, 2013

    robgendreau macrumors 68040

    Joined:
    Jul 13, 2008
    #1
    I've got this little character popup that keeps showing up to display accented characters, and slows down typing. I can't seem to find a way to make it go away, and I'm not even sure of it's source (system or added software). I've tried different keyboard layouts (US, Canadian, PC) to no effect, as well as setting relating to the Character Viewer (the big one in System Preferences). The only other utility I could think of was Typinator, but it's not in there either. Seems to occur mostly in Safari when writing in forums like this.

    Here's the little devil below.

    Oops. Found it; turns out it is the ApplePressAndHoldEnabled preference. See this page:
    http://osxdaily.com/2011/08/04/enable-key-repeat-mac-os-x-lion/

    I have no idea how I enabled it, but now it's off. You can use Terminal or, as I did, MacPilot or similar utility.
     

    Attached Files:

  2. guitarman777 macrumors regular

    guitarman777

    Joined:
    Sep 15, 2005
    Location:
    Orlando, FL
    #2
    I seem to remember fixing this within System Prefs, lemme take a peek...

    Then again, I believe you're right! MacPilot is where I fixed that. TinkerTool also has that option under General > Keyboard.
     
  3. robgendreau thread starter macrumors 68040

    Joined:
    Jul 13, 2008
    #3
    Kind of odd that a useful addition like this would be so hidden.
     
  4. 50548 Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #4
    Just type this in Terminal and then log out/back in again:

    defaults write -g ApplePressAndHoldEnabled -bool false
     

Share This Page