how do i stop my airport internet access

Discussion in 'macOS' started by johnoooo, Apr 8, 2010.

  1. johnoooo macrumors newbie

    Joined:
    Apr 8, 2010
    #1
    hi.
    i have a small problem, i am a student, but i spend way too much time on chat rooms, and its getting to be a real problem. we have airport in my parents home and my laptop is hooked up to it. i had to enter a password originally to join the network connection, but now i just want to block access, from my laptop, to the family connection, so that i can only use my parents computer for the internet... ie so it will ask me for a password again for my laptop to get online, and wont just automatically be connected (i dont have this password any more so i wont be able to spend hours wasting time on the net!!)
    please help, im at my wits end!!
    johnoo
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    System Preferences > Network > AirPort > Advanced > AirPort

    [​IMG]

    Either click the MINUS button to delete the network or de-select "Remember any network this computer has joined".

    You can also setup the router at home to not allow your computer access to the network, thus internet, with the help of MAC address filtering.
     
  3. johnoooo thread starter macrumors newbie

    Joined:
    Apr 8, 2010
    #3
    still no luck

    thanks for that, but its not working still. first of all im on OSX, and the options seem a little different in network (see attached), i can click the "minus" button, but even when i "lock" the changes before i leave, it still connects automatically when i open explorer. I dont have the option to turn on/off "remember any network this computer has joined" ...anyhow ,would appreciate any other tips, otherwise ill take a look at "mac address filtering"
    thanks again!
    j
     

    Attached Files:

  4. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #4
    Two Ways can think of:

    1) Open up Keychain, and delete the entry for your Network password. You should then be prompted for it next time you try to connect to the Network.

    2) Create a new Standard User Account and use Parental Controls to limit internet access on that account.
     
  5. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #5
    I'm on OS X too, the screenshot even shows OS X, just a newer version.

    You probably have Mac OS X 10.3/4, so what happens if you click on the drop down where it says By Default: join Preferred networks?

    Isn't there an option to not "join" or delete?

    It's been a while since I used Panther or Tiger, so I don't remember the exact steps.
     
  6. designgeek macrumors 65816

    designgeek

    Joined:
    Jan 30, 2009
    Location:
    "Town"
    #6
    Hi, I had to dig up an old OS X Tiger computer to figure this out. When you're in the "Preferred Network" pane, click on Options. Try de-selecting "Automatically add new networks to the preferred networks list" then click "Apply now."

    [​IMG]

    Is that what you're looking for?
     

Share This Page