How do I stop Safari selecting tabs when they load?

Discussion in 'Mac Apps and Mac App Store' started by aussiemac86, May 10, 2008.

  1. aussiemac86 macrumors 6502

    Joined:
    Apr 12, 2004
    Location:
    the land of OZ
    #1
    Hi everyone,

    Something has been irritating me lately;

    I'll often be working in Safari with several tabs open, i'm using a slower internet connection at the moment, so i'll have something loading in a background tab, whilst im looking at another one. With certain webpages, when it has finished loading Safari will automatically switch to that tab, taking me away from the tab i was looking at.

    This can be especially annoying if im trying to type something into the other tab.

    It seems to only happen with webpages where I'm required to sign in, gmail is one of them, it doesnt happen in firefox.

    Anyone know any solutions?

    Im running 10.4.1 and Safari 2.0.4

    Cheers
     
  2. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #2
    Check Safari --> Preferences --> Tabs and make sure that the "Select tabs and windows as they are created" option is unchecked. Mine is, but I do still find what you describe happening every once in a while...the vast majority of the time it works fine though.
     
  3. aussiemac86 thread starter macrumors 6502

    Joined:
    Apr 12, 2004
    Location:
    the land of OZ
    #3
    Yeh the above option is unchecked. Cheers for the suggestion though
     
  4. snuffdaddy macrumors member

    Joined:
    Oct 28, 2007
    #4
    Yeah this p*sses me off quite a bit also. I've searched a few times in the past and never found a solution. I don't think its a problem with the browser... I've come to understand that some websites have a code that tells the browser to open that tab/window when loading has finished. Though there may be some kind plug-in or something designed to override this, I'm not sure.
     
  5. jdavtz macrumors 6502a

    Joined:
    Aug 22, 2005
    Location:
    Kenya
    #5
    Are you using the "new version" Gmail? I used to have the same problem as you, but now I don't. I think it was 'fixed' by either Gmail switching to its 'new version', or installing Safari 3.1.1 -- can you install that on Tiger? (Do you mean 10.4.1 or 10.4.11?) You could always try the latest Webkit build from www.webkit.org which won't overwrite your Safari if you're on 2.0.4 for a reason, and see if Gmail behaves itself in that version.
     

Share This Page