How do I stop the mail app from downloading all my emails?

Discussion in 'Mac Apps and Mac App Store' started by mcsolas, Dec 10, 2014.

  1. mcsolas macrumors regular

    Joined:
    Jan 4, 2013
    #1
    I have a gmail account I have used for a while, so there are heaps of old messages in the all mail folder. I have been traveling a lot and trying to start using the folders on the server rather than how I used to - which is organize them locally ( I was using Thunderbird / POP config ). I tried IMAP on both Thunderbird and the Mail app and ran into the same problem. No matter what I do, I can't seem to stop it from downloading the entire contents of the All Mail folder.

    In thunderbird there was a way to uncheck the subcription to that folder but either it was a glitch or something funny would happen and I would uncheck it, then open that dialog up again and it would be checked. So I try the mail app and it did the same.. but even worse, somehow during this process my anti-virus caught a few virus downloads that were in attachments. As well, I couldn't find anywhere in the settings where I could unsubscribe/selectively avoid downloading that folder.

    Is there any way to get IMAP working with gmail and not have this 'all messages' landslide occur?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  3. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    Well, gmail's implementation of IMAP takes the spec a bit loosely. That said, I think you can still go to gmail on the web, find the settings page, find the Labels tab, find the IMAP options and uncheck the box says to show All Mail to IMAP clients.

    Disclaimer: I have moved off of gmail and only use it in a legacy sort of way so I might be out of date regards to features.

    A.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Yes, you can uncheck the "Show in IMAP" which will prevent the "All Mail" label from appearing, but that doesn't prevent all email messages from being downloaded.
     
  5. mcsolas thread starter macrumors regular

    Joined:
    Jan 4, 2013
    #5
    There was some useful info in that thread, maybe a way to configure the mail app to work by limiting it by date.. thanks.

    Alrescha - I just went in and found the setting I may need to adjust.. it was the last one on that page. I set it to limit folders to 1000 messages. I think that may help improve the situation.
     
  6. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #6
    Well, downloading the 'All Mail' folder was the documented problem...

    A.
     
  7. mcsolas thread starter macrumors regular

    Joined:
    Jan 4, 2013
    #7
    Ok, I figured a few things out. Thunderbird will retain the settings, but it seems that you have to:

    Unsubscribe the relevant folders > quit the app > then open and it should no longer download the messages.

    It was also interesting that you can limit the IMAP downloads to 1000 on gmail. I think this is a very noteworthy gmail setting that is probably often overlooked (I see now this type of question pops up a lot in various forms). I had even looked at that tab in gmails settings thinking I might find the solution. With it being tucked away at the bottom of the page and I missed it on the first pass. Thanks for pointing that out and helping me in this thread. :cool:
     

Share This Page