How do I turn off resume for applications after restart?

Discussion in 'Mac OS X Lion (10.7)' started by KyleGP, Jul 22, 2011.

  1. KyleGP macrumors member

    Joined:
    May 3, 2011
    #1
    Basically, if I have a bunch of apps open in lion and I restart, they all re-open after restart as I had them before. Okay, that's a feature, but it's a feature I don't want. When I restart my system, I'm starting again.

    How can I make it so all the apps I had open don't resume?

    This has nothing to do with the option under general. That's resuming of contents inside an app. I'm talking about resuming of programs after restart. They all just pop up!
     
  2. RWil85 macrumors 6502

    Joined:
    Aug 2, 2010
    #2
    isn't there a checkbox to uncheck that disables that function when you go to to shutdown/restart?
     
  3. b-rad g macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #3
    I believe it a checkbox when you press the power button to shutdown or restart. When the box comes up to choose shutdown just uncheck the box that say to resume all open apps or something like that.
     
  4. DandsM macrumors member

    Joined:
    Jan 31, 2011
    #4
    Unchecking that box every time you restart/shutdown is not so pleasant. :D
     
  5. KyleGP thread starter macrumors member

    Joined:
    May 3, 2011
    #5
    Yes, there is, but I mean to disable it fully without having to uncheck it each time.

    Plus one of my apps restarted the computer as part of an installation and did not show that dialogue so I had no option but to let them all pop up again after it rebooted.
     
  6. b-rad g macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #6
    Is it everytime? I would have thought thet it would stay unchecked everytime until you checked it back.
     
  7. DandsM macrumors member

    Joined:
    Jan 31, 2011
    #7
    No, unfortunately it is every time. :(

    They should put this option under System Preferences.
     

Share This Page