How do I turn off the internal mic on my macbook?

Discussion in 'Digital Audio' started by frogspawn, Mar 17, 2009.

  1. frogspawn macrumors newbie

    Joined:
    Mar 17, 2009
    #1
    Hi all,

    I am trying to record some flute music for my daughter for her school assessments using the iPas program. The internal mic doesn't seem to be consistent enough to provide a good quality recording. Sometimes good sometimes bad.

    I have tried a simple plug in mic, with no success. I read that they don't have enough signal and require a pre amp... so thats out.

    I then tried a Logitec desktop USB mic, the mac book pics up sound OK but when I try to record it seems to default back to the internal mic. I know this is the case because I turned the input level down in the system pref pane for the internal mic and up on the USB mic, then there is no sound available to the iPas program. If I leave the level on the internal mic up I get the same poor quality as before.
    I have even tried the USB interface mic I have from the Sony playstation Singstar, with the same result.
    I know of others who use this with success on a PC, I don't want to admit the PC is more friendly!!!!!!!!

    I have set the default mic to the USB mic in the utilities/audio/midi.
    The USB desktop seems to work OK on my mac mini as it has no internal mic to default to.

    Help! My emotional 13 YO will of course "like totally freak" if I can't sort this out and use the macbook.

    Cheers,
    Graham.
     
  2. ashjamben macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #2
    i'm not familiar with the program your using, any reason why your not just using garageband?

    anyway, my guess will be in the ipas program go to file>preferences and there will be an audio input choice. it will probably say internal mic at the moment. when the usb mic is plugged in it should come up as an available input method.
     
  3. frogspawn thread starter macrumors newbie

    Joined:
    Mar 17, 2009
    #3
    Unfortunately iPAS is the program that "MUST be used", as it comes with the Standard Of Excellence music book all the students use.
    There is no file/preference to open in this prog. It is by Pyware.
    When setting up for a recording session the prog looks for a mic if it can't find one it looks again, and again...... it seems to recognise the mic but fails to pick anything up.
     
  4. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #4
    Have you tried using the "audio midi setup" program? It is in the applications folder. Use it to set which of the audio input is the default. (It's the app that has a one octave wide piano keyboard for its icon.)

    Sounds like you are running up the same sound quality ladder is many of us have. Start with the internal mic, find that it is not designed for music then go with a low cost USB mic, and well, there are many more steps left
     
  5. frogspawn thread starter macrumors newbie

    Joined:
    Mar 17, 2009
    #5
    Yes ChrisA,

    I set the USB mic as the default in the audio/midi pane but it still uses the internal mic.

    Graham.
     
  6. ashjamben macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #6
    sorry i have no idea then.

    i imagine the program should have some sort of option to choose the input though, somewhere.

    tried the programs website for a technical helpline/email?
     

Share This Page