How do I unbrick an AppleTV?

Discussion in 'Apple TV and Home Theater' started by HolyJaw, Sep 27, 2007.

  1. HolyJaw macrumors newbie

    Sep 27, 2007
    Today, 9/27/07, I bought an AppleTV, software version 1.0, (yes, zero). I wanted to play AVI and DIVX, etc., so I did some research, leading me to some modding/hacking guides.

    I followed Engadgets guide here:

    On how to open up the ATV, connected the HD to my MBP via IDE>USB that I bought at Fry's, and did some work on it...

    Enable SSH on the Apple TV (requires a Mac)
    Remove the drive the same way we did to expand the drive and plug it into a Mac, then launch Terminal. Our first command is going to copy the Intel version of ssh daemon from our Mac to the ATV drive. If you are on a Intel Mac copy it from your sbin directory to the ATV's OSBoot/usr/sbin/ directory. If your browser causes the line to wrap be sure to enter it on one line in the Terminal.
    sudo cp /usr/sbin/sshd /Volumes/OSBoot/usr/sbin/
    You can also copy it from your downloads directory:
    cp /Users/Engadget/Downloads/sshd /Volumes/OSBoot/usr/sbin/
    Make sure sshd is executable
    sudo chmod +x /Volumes/OSBoot/usr/sbin/sshd
    Backup the original ssh.plist to our home directory:
    cp /Volumes/OSBoot/System/Library/LaunchDaemons/ssh.plist ~
    Now copy the new one from our downloads directory to the Apple TV drive:
    cp /Users/Engadget/Downloads/ssh.plist /Volumes/OSBoot/System/Library/LaunchDaemons/
    Before we dismount the drive to reinstall into the Apple TV, let us see if we need to clean up after Spotlight again.
    Perform these command and check if the .Spotlight files are on the partitions by typing:
    ls -a /Volumes/Media
    ls -a /Volumes/OSBoot
    Now, if you do see those .Spotlight files, use the following command to remove them. But be careful, this is the dreaded rm -rf command, which has the potential to ruin everything.
    sudo rm -rf /Volumes/OSBoot/.Spotlight-V100
    sudo rm -rf /Volumes/Media/.Spotlight-V100
    Now dismount the drive and install it in your Apple TV. If you need to give your friend's Mac back, feel free. From here on out you can fly PC on this op, if you so choose.
    Three things:

    When I first did the sudo command I got a prompt telling me sudo could fubar everything and asked for my admin password, so I gave it. Then terminal gave me a new empty line without confirmation (as I'm used to) so I repeated the command again and once more, only to realize that it wouldn't give me confirmation. I assume this would not harm my ATV.

    I got halfway through the instructions to

    I did see the .Spotlight folders in both partitions, so I followed the instructions with the rm -rf commands.. the potentially dangerous ones. I believe this might be where I bricked it.

    Then after following the rest of the instructions I got to the

    I was unsure as to HOW to dismount, so I looked up some terminal/bash commands and found that

    diskutil unmount disk1 (it was /dev/disk1/) should cover it. So I typed that, and to ensure that it was unmounted, i did

    diskutil list.

    It showed disk1 and it's partitions as still being there as if the command didn't work. So I tried

    diskutil eject disk1 and
    diskutil list

    with the same result. I tried this over and over unsure of how to proceed until finally my stupid little brain said, hey it must be OK now, go ahead and just disconnect. THIS I figure is wherein the problem lies.

    Once I put everything back together properly (all scews in the exact placement as they were before, even) I plugged in the ATV... now the light is flashing

    blank, white, blank, yellow, repeat.

    The TV is receiving no signal, and I can't

    ssh -1 frontrow@AppleTV.local

    I figure this is sign 1 of Brick-Town.

    I hope to get an answer soon, otherwise... well I hate to have anyone know that I just bought a $300 brick.
  2. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    I'm no expert, but I think you want -l (dash L), not -1 (dash one).
  3. HolyJaw thread starter macrumors newbie

    Sep 27, 2007
    Only problem is ATV is completely off the grid. I copy/pasted it exactly but to make sure I checked the ssh usage in bash... -1 is the first flag... but -L is there too... except -L only returns a usage error... -1 returns...

    ssh: AppleTV.local: No address associated with nodename
  4. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    Lowercase l.
  5. HolyJaw thread starter macrumors newbie

    Sep 27, 2007
    ssh -l frontrow@AppleTV.local


    It says right on the fifth line that -l followed by a login name (frontrow@AppleTV.local?) should be acceptable... so why does it return a usage error?

    And why is my ATV still blinking white and yellow? =[
  6. ger-ethan macrumors newbie

    Jul 30, 2007
    Frankfurt, Germany
  7. HolyJaw thread starter macrumors newbie

    Sep 27, 2007
    Thanks so far--

    I went in today and retraced all my steps, found that the .Spotlight- folders were still there so I got rid of 'em using the "dangerous" method. Put everything back together and voila, perfect!
  8. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    As mentioned, I'm not an expert :)
  9. mr_matalino macrumors 6502a


    Oct 14, 2005
    Have you tried to run a diagnostic on it yet? Push and hold menu and the (-) button for 10 seconds. This should force it to boot on the other partition which holds a factory restore OS.

Share This Page