How do I upgrade gimp 2.4.4 to 2.6.10?

Discussion in 'Mac Basics and Help' started by nightsky, Sep 19, 2010.

  1. nightsky macrumors member

    Joined:
    Feb 18, 2007
    Location:
    SA,Tx
    #1
    G4 15", tiger 10.4.11 and have gimp 2.4.4 installed. I want to upgrade to gimp 2.6.10. Question is do I need to uninstall older gimp version before installing the new version? Thanks
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Depends on how you installed Gimp in the first place.

    If you used a prebuilt binary originally, and are replacing it with a newer binary, no uninstallation is necessary - though I do recommend removing the older Gimp.app version after you install the new one.

    If, on the other hand, you compiled it from source originally, uninstallation is strongly recommended - due to differences in files between the two versions. In this case it doesn't matter if you're using a prebuilt binary or compiling from source again.
     
  3. nightsky thread starter macrumors member

    Joined:
    Feb 18, 2007
    Location:
    SA,Tx
    #3
    Upgraded Gimp successfully

    Thank you, I had installed a binary pkg. and after googling, searching this forum, as well as, gimp forum- noticed all the problems people were having installing gimp on OSX, so i decided put the old version of gimp.app into trash, did a secure empty trash, dragged the new gimp.app to application folder presto gimp installed smoothly. Of course I had an upgraded version of X11 installed already on the system.
    Your response is informative, helpful and much appreciated... I am sure others will benefit. Simple basic questions are the hardest to find answers for it seems to me.
     

Share This Page