How do I verify phone number for iMessage?

Discussion in 'iPhone' started by SomeonePlzHelp, Dec 25, 2011.

  1. SomeonePlzHelp macrumors regular

    Joined:
    Aug 31, 2011
    Location:
    California
    #1
    So when I go to iMessage settings this is what pops up.
    [​IMG]

    It for some reason has my number greyd out...
    So like if someone new texts me, and then it switches to the blue (iMessage) when I go to reply, all of a sudden it changes to showing my email address when they get my message.

    My friend said I have to have it set to receive at phone number instead of email address. How do I go about doing that?
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Turn iMessage off wait then back on
     
  3. SomeonePlzHelp thread starter macrumors regular

    Joined:
    Aug 31, 2011
    Location:
    California
    #3
    Wow that did it. Thanks man!
    Merry Christmas.
     
  4. ecwhite4S macrumors 6502

    Joined:
    Dec 17, 2011
    Location:
    Los Angeles, CA
    #4
    Having this same problem right now. I restored last night, was reading through the battery topic and people said that restoring might help battery life (not that mines horrible I just thought it wouldnt hurt), and now my friends are saying that my texts are coming from my email.

    When I go to iMessage in settings, it has RECEIVE AT: 2 ADDRESSES

    In the addresses part, my phone number is greyed out, and my email is in black (ok, I'm sure the number is grey because it cant be changed at all), well when I go in to remove the email address it doesn't let me.

    Hmm. This is the first weird thing I've noticed on my 4S, and it's probably just me being an idiot and doing something wrong.

    And I've turned it on/off. Maybe I'll switch it off and wait a while.

    EDIT: Okay, so I waited a bit, and switched it back on, and it took like 10 seconds to activate, but lemme ask, are you supposed to be able to delete your email? Cuz it still wont let me.
     
  5. SomeonePlzHelp thread starter macrumors regular

    Joined:
    Aug 31, 2011
    Location:
    California
    #5
    No there has to be an email address, that's how iMessage works remember? It's through your email too.
     
  6. ecwhite4S macrumors 6502

    Joined:
    Dec 17, 2011
    Location:
    Los Angeles, CA
    #6
    That's what I thought, but my friend is still saying that when I text him when iMessage is on, it's showing up as coming from my email address. When I turn iMessage off, it's back to normal (obviously). Hmm.

    Even under "caller ID" in iMessage it has a check mark next to my phone number and no check mark by my email.
     
  7. KKSigs macrumors member

    Joined:
    Jul 1, 2010
    #7
    Not true, you can just use your cell number for iMessage. All you have to do is sign out. I have people use email if they want to iMessage me via iPad. This prevents redundant texts
     
  8. ecwhite4S macrumors 6502

    Joined:
    Dec 17, 2011
    Location:
    Los Angeles, CA
    #8
    I restored as a new phone, didnt want to, but did anyway. Seems to be working fine now. I now have build 9A406 of iOS.
     
  9. SomeonePlzHelp thread starter macrumors regular

    Joined:
    Aug 31, 2011
    Location:
    California
    #9
    Oh so I can sign out of the email address part and it will only iMessage to my phone number?
     
  10. KKSigs macrumors member

    Joined:
    Jul 1, 2010
    #10
    yup thats correct
     

Share This Page