How do you activate Messages in the cloud?

naasrd

macrumors 6502
Original poster
Apr 30, 2008
431
127
Dublin, Ireland
There doesn't seem to be any clear cut way to activate this; some people have it on, others don't, mine is still greyed out. Are there any steps you have to take, do all devices have to be running the betas? Mine are. I have Messages turned on in iCloud settings on phone and pad. Can anyone shed any light on this please?
 
  • Like
Reactions: Craiguyver

fisherking

macrumors 604
Jul 16, 2010
6,716
1,688
ny somewhere
messages store automatically in the cloud, there isn't anything to turn on... or off. but you don't access them there; only on your devices (mac, iphone, etc).
 

BrettDS

macrumors 65816
Nov 14, 2012
1,088
223
Orlando
messages store automatically in the cloud, there isn't anything to turn on... or off. but you don't access them there; only on your devices (mac, iphone, etc).
Actually, storing iMessages in the cloud is a new iOS 11 feature and you do, indeed need to turn it on to use it.

Unfortunately I can’t help with the question of why it’s greyed out for some people. I was able to turn it on while I was on beta 1 and it’s stayed on for me through beta 3.
 

Yun0

macrumors 65816
Jun 12, 2013
1,492
753
Winnipeg, Canada
its still broken anyway, beta 2 said it couldnt update icloud settings at this time, beta 3 it turns on and looks fine, but never syncs. still says last sync is jun 23 from beta 1 from that 1 time it did work. rebooted etc, watched router traffic graphs for an hour, wifi interface is flat lined so its not silently doing it either.
 

fisherking

macrumors 604
Jul 16, 2010
6,716
1,688
ny somewhere
Actually, storing iMessages in the cloud is a new iOS 11 feature and you do, indeed need to turn it on to use it.

Unfortunately I can’t help with the question of why it’s greyed out for some people. I was able to turn it on while I was on beta 1 and it’s stayed on for me through beta 3.
i stand corrected. there IS that option in preferences (i was thinking of my mac, where it seems to be on without my selecting anything.)
 

tigertazz

macrumors 6502
May 4, 2009
285
318
I’m on PB 1 and it’s been syncing fine for me.
I turned it on day one and it’s been syncing ever since (as far as I’m aware, I don’t check that regularly)
 

Attachments

Donfor

macrumors member
Aug 14, 2016
89
15
This is a new feature I wasn’t aware of

Yet whilst I since found the icloud messages option it’s greyed and unable to switch on via pb1

Turned on restrictions to allow make changes to icloud
Turned off restriction

store messages on icloud is still greyed
[doublepost=1499754850][/doublepost]since found this
You must turn on Two-Factor Authentication for your Apple ID in order to use the 'Messages on iCloud' function at this time. Hopefully this changes, but it's very likely to stay!

I dont want to return to two factor authentication

I can live with standard keep messages for 1year
 
Last edited:

MozMan68

macrumors 68040
Jun 29, 2010
3,075
955
Right here...
I actually like it the old way (turned off and not synching). Let's me keep messages on my phone clean while saving them on my Mac for future reference.
 

Feenician

macrumors 603
Jun 13, 2016
5,180
4,788
I actually like it the old way (turned off and not synching). Let's me keep messages on my phone clean while saving them on my Mac for future reference.
You could still do that by simply not enabling iCloud sync for messages on the Mac in High Sierra. That would still keep any iOS devices in line but allow you to use the Mac for archival.
 

utwarreng

macrumors 6502
Aug 8, 2009
381
63
Now that I have my messages synced through iCloud, I wish that I could send and receive them through iCloud from my Windows desktop
 

naasrd

macrumors 6502
Original poster
Apr 30, 2008
431
127
Dublin, Ireland
This is a new feature I wasn’t aware of

Yet whilst I since found the icloud messages option it’s greyed and unable to switch on via pb1

Turned on restrictions to allow make changes to icloud
Turned off restriction

store messages on icloud is still greyed
[doublepost=1499754850][/doublepost]since found this
You must turn on Two-Factor Authentication for your Apple ID in order to use the 'Messages on iCloud' function at this time. Hopefully this changes, but it's very likely to stay!

I dont want to return to two factor authentication

I can live with standard keep messages for 1year

Thanks, tried that but still no joy.
 

Dwalls90

macrumors 601
Feb 5, 2009
4,690
1,064
Now that I have my messages synced through iCloud, I wish that I could send and receive them through iCloud from my Windows desktop
I feel like this will be a future feature, which is why we’re seeing the option to put our messages in the cloud versus syncing between Apple devices. This would be a great way to combat Google Hangouts.

Thanks, tried that but still no joy.
It’s not working for most users. I feel as if since this is a big backend/cloud feature, we’ll see this functioning more reliably later in the beta cycle.
 

tivoboy

macrumors 68040
May 15, 2005
3,069
194
I feel like this will be a future feature, which is why we’re seeing the option to put our messages in the cloud versus syncing between Apple devices. This would be a great way to combat Google Hangouts.
Indeed and imessage access through the icloud portal is totally on the way.. bet on it.
 

lsutigerfan1976

macrumors 68030
Sep 14, 2012
2,527
1,463
I actually was having problems with iMessage one day. So I tried turning off iMessage, and sync messages with cloud. I was able to turn iMessage back on. But for the life of me, I cannot get messages to sync with iCloud again. It's just greyed out, and no matter what I tried. I can't activate it again.
 
  • Like
Reactions: Craiguyver

Craiguyver

macrumors member
Jan 26, 2013
69
91
Minnesota, USA
I actually was having problems with iMessage one day. So I tried turning off iMessage, and sync messages with cloud. I was able to turn iMessage back on. But for the life of me, I cannot get messages to sync with iCloud again. It's just greyed out, and no matter what I tried. I can't activate it again.
I have the same exact issue. Would sure love to know how to reactivate iMessage-iCloud sync again. Button grayed out here as well.
 
  • Like
Reactions: lsutigerfan1976

lsutigerfan1976

macrumors 68030
Sep 14, 2012
2,527
1,463
I have the same exact issue. Would sure love to know how to reactivate iMessage-iCloud sync again. Button grayed out here as well.
I have managed to turn imessages saved in iCloud on from my phone. My iPad however is still greyed out. I can’t switch it on my iPad at all.
 

LarryJoe33

macrumors 68000
Jul 17, 2017
1,566
505
Boston
I turned it on on both my iPhone 7 and my Mac with the install of the first Public Beta's. After installing PB2 on both devices, it's still working on my phone but it is now grayed out on my Mac. I do wish/hope that it actually syncs going forward, i.e. delete from phone and it's deleted from the Mac. It did not do this with PB1 when both were enabled.

EDIT: I decided to try this and it indeed worked. I deleted a message on my phone and witnessed it being deleted at the same time on my Mac. Cool. However, it is greyed out on my Mac but I really think it is on. I get a blue bar on my mac at the bottom of messages like it is syncing/uploading.
icloud message.png

Yes, it is enabled and available
message Sync.png

and it is syncing per the bar above
 
Last edited:

lsutigerfan1976

macrumors 68030
Sep 14, 2012
2,527
1,463
Seems like by turning iMessage off and then on again, all my old messages are gone. The only thing that happens now is it syncs any new messages I have. But I am not sure what happened to my old messages.
 

apb89

macrumors regular
Aug 25, 2012
149
30
I had enabled it at one point but it seems to have deleted some messages I noticed I have many messages missing from like November 2016 to June 2017 for most of my major threads. I noticed when it began syncing that it notified me with A LOT of 'this message could not be sent' notifications... I think this was related to the missing messages.

It kind of annoys me but it is beta at this point and I also am upset because I like to keep every message..
 

fisherking

macrumors 604
Jul 16, 2010
6,716
1,688
ny somewhere
i don't see the point (or at least, not until we can access messages on the icloud site), and it eats up a lot of space on my (basic) icloud storage. with it off, as always, my messages sync (between my mac & iphone). will keep it off (for now)...