how do you delete guest account?

Discussion in 'OS X El Capitan (10.11)' started by pat500000, Jun 15, 2016.

  1. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #1
    I've been trying to figure this basic out...but no way to delete it. Any suggestion?
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    When a guest user logs out, all information and files in the guest account's home folder are deleted.
    And, when you disable the guest user in the Users & Groups pref pane, the guest user is not available.
    If the files for the guest user are deleted, and the guest user is disabled - what more do you need?
     
  3. pat500000 thread starter macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #3
    Maybe it's just me...but I don't even remember guest user existing unless I make one.
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    The guest user is a built-in feature of the OS X system, and the guest user is available if you have a need for it. Nothing happens with the guest account unless you allow guest access, and someone wants to log in as a guest user. Info/files that have been created by the guest user are deleted from that account when the guest logs out.

    If you don't want any access to the guest account, then choose to disable it in your Users & Groups pref pane.
     
  5. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #5
    As mentioned above, it's an OS feature, the best you can do is disable it in System Preferences > Users & Groups. Sometimes it will be reenabled following system updates and you'll have to disable it again, not sure why that is.
     
  6. pat500000 thread starter macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #6
    Gotcha okay. So it's a feature. Haven't had to access there in awhile. Thx.
     
  7. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #7
    A guess (I haven't dug into these things for a long time): where FileVault 2 is enabled, allowing guest access may be desirable because if the computer is stolen, then the next person who logs on as a guest might make the machine visible for tracking/remote erasure purposes. Something like that.
     
  8. pat500000 thread starter macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #8
    Very soundable.
     
  9. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #9
    I don't have FileVault enabled on my 13" rMBP, yet the guest account is enabled after installing the MacOS Sierra beta. I don't think this was true before the install, and I know I have disabled it before.
     
  10. nnyymm macrumors regular

    Joined:
    Nov 30, 2010
    Location:
    Singapore
    #10
    You can only disable it and if it doesn't go away even after disabling when you reboot, you can try the following...

    1. Make sure “Find My Mac” and Guest User are disabled, reboot;

    2. Check whether System Integrity Protection is enabled or disabled by running: csrutil status at the Terminal.

    3. If it says "System Integrity Protection status: enabled." proceed to 4.1,

    4. if not, only do 4.4 and 4.7;

    4.1. Reboot into "Recovery Mode": Shutdown and hold Command + R after pressing the power button;

    4.2. Go into "Utilities > Terminal" and run the command: csrutil disable;

    4.3. Reboot;

    4.4. Open the Terminal and run: sudo touch /System/Library/PrivateFrameworks/EFILogin.framework/Resources/EFIResourceBuilder.bundle/Contents/Resources, this will force the EFI login update;

    4.5. Reboot(again) into "Recovery Mode": Shutdown and hold Command + R after pressing the power button;

    4.6. Go into "Utilities > Terminal" and run the command: csrutil enable;

    4.7. Reboot and it’s fixed!

    4.8. Re enable “Find My Mac” as you wish.
     
  11. pat500000 thread starter macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #11
    Thanks! Will try that.
     

Share This Page