How do you delete unwanted WiFi addresses from...

pachyderm

macrumors 603
Original poster
Jan 12, 2008
6,394
1,688
Smyrna, TN
This little icon at the top of my MacBook screen?

Screen Shot 2020-02-09 at 8.12.54 AM.png


Whenever I log on these days a lot of my neighbors wifi addresses pop up plus "xfinitywifi" and even our old printer has 3 in the list!

I have to physically go in and select my wifi almost every time.

I have searched it on google but the help I found didn't work.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,783
9,410
California
Open System Preferences, then Network, then select wifi in the left column. Then click Advanced in the lower right. You should now see a history list networks you have used. Just click the one you want to remove and click the minus to remove it.
 

pachyderm

macrumors 603
Original poster
Jan 12, 2008
6,394
1,688
Smyrna, TN
Open System Preferences, then Network, then select wifi in the left column. Then click Advanced in the lower right. You should now see a history list networks you have used. Just click the one you want to remove and click the minus to remove it.
That is what google said and it didn't work. :(
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,783
9,410
California
Click the advanced button at the lower right there to see the list of previously used networks. Then select and click minus to remove.
 
  • Like
Reactions: pachyderm

pachyderm

macrumors 603
Original poster
Jan 12, 2008
6,394
1,688
Smyrna, TN
Click the advanced button at the lower right there to see the list of previously used networks. Then select and click minus to remove.
Screen Shot 2020-02-09 at 9.41.43 AM.png


Nothing has been happening.
- - Post merged: - -

Screen Shot 2020-02-09 at 9.48.46 AM.png


This is the menu I get and I can't find a way to get to it to delete anything.

In the images I posted above this one, those wifi addresses don't even show up.
- - Post merged: - -

@Weaselboy - Thanks for trying to help me!
 
Last edited:

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,783
9,410
California
I see your question. Two different issues here. The first screenshot is a list of networks you have previously joined, and you should be able to remove those like I described by selecting each one then clicking the minus to remove it.

The second screenshot is just showing available wifi devices near you and there is no way to hide those.
 

Bandaman

macrumors 6502
Aug 28, 2019
479
1,041
Yeah dude ... you can't hide the available Wi-Fi all around you. Why that's bothering you is beyond me ... since literally every device on the face of the earth that can connect to Wi-Fi does that ...
 
  • Wow
Reactions: pachyderm

dangerfish

macrumors 6502a
Aug 28, 2007
551
121
Why are you even looking in the available network drop down? If you’ve told the computer to automatically connect to your home WiFi network, it should do it automatically without needing to go into that drop down.
 
  • Wow
Reactions: pachyderm

mikzn

macrumors 68000
Sep 2, 2013
1,689
949
Vancouver
I have to physically go in and select my wifi almost every time.
I have seen this on many posts over the years and have a friend with a couple MBP's and one of the MBP's keeps loosing the default network like this and he has to manually select it to get it connected - then is good far a while but will eventually drop the connection again - probably IP confusion with multiple macs - iphones and printers etc..

I don't know if this will help - just thought - have you tried resetting the default "most preferred" wifi network by dragging it to the top of the window - if it is already there try moving it down - close the preferences (to save) and then open it back up and reset it back to the top of the list (close to save again) - see snap shot below

not sure if that will make any difference - but maybe worth a shot?


pachyderm.png
 
  • Like
Reactions: pachyderm

StevePaselli

macrumors newbie
Jun 6, 2016
14
2
Italy
No need to hide neighborhood networks from the menu. But watch out for “captive” wifi networks (those with “Security: NONE”. These redirect you to a login window and can be hard to avoid. Just make sure you network SSID appears at the top of the list in System Preferences/Network/WiFi/Advanced.
 
  • Like
Reactions: pachyderm

Ruggy

macrumors 6502
Jan 11, 2017
362
197
It sounds like your preferred network isn't very strong or is getting interference for some reason.
You've got it set up and remembered as the preferred network and to auto connect and if it's strong, then that's what it will do but if the neighbouring networks are better, then it will present you with the list and ask you if you want to connect to them instead.
If you don't have the 'ask to join new networks ' enabled then it shouldn't offer them to you but it may be worth your while checking that you are getting a good signal, the best channel etc.
 
  • Love
Reactions: pachyderm

pachyderm

macrumors 603
Original poster
Jan 12, 2008
6,394
1,688
Smyrna, TN
It sounds like your preferred network isn't very strong or is getting interference for some reason.
You've got it set up and remembered as the preferred network and to auto connect and if it's strong, then that's what it will do but if the neighbouring networks are better, then it will present you with the list and ask you if you want to connect to them instead.
If you don't have the 'ask to join new networks ' enabled then it shouldn't offer them to you but it may be worth your while checking that you are getting a good signal, the best channel etc.
Thanks!
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,639
995
It sounds like your preferred network isn't very strong or is getting interference for some reason.
[...]
but it may be worth your while checking that you are getting a good signal, the best channel etc.
Along those lines: option-click the wifi icon in the menu bar. "Open Wireless Diagnostics". Don't click on anything. Instead, go to menu-bar > Window > Scan. In the resulting window, you'll see a box on the left. In that, there will be a line for "best 2.4/5.0": that tells you which channels are the best to use for your router given the local wifi environment.

At that point, can change the channels on the router and see if things are working better.
 
  • Like
Reactions: pachyderm