How do you Format a USB on a macbook air

Discussion in 'OS X Mavericks (10.9)' started by hssxn, Apr 6, 2014.

  1. hssxn macrumors newbie

    Apr 6, 2014
    I have a lexar USB 32GBs and it has its permissions set as read-only and it is formatted as FAT32 and it can't be formatted in disk utility since it is greyed out and it unable to even recognize it there. PLEASE HELP
  2. yjchua95 macrumors 604

    Apr 23, 2011
    GVA, KUL, MEL (current), ZQN
    Try plugging out and plugging in. If it still doesn't work, try to click on the USB icon, press Cmd+I and change its permissions.
  3. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    Is it just the FAT32 formatted partition/volume that is greyed out? Try selecting the drive brand name itself just above the partition name and then go to the erase tab and see if you can format.
  4. hssxn thread starter macrumors newbie

    Apr 6, 2014
    Usb format

    I tried plugging it in and out and it doesnt recognize it overall. also clicking the name just above the partition doesnt work as well. my USB is READ ONLY so i need a way to make it writable again

Share This Page