How do you get pages to use British english?

Discussion in 'Mac Apps and Mac App Store' started by henry.oswald, Nov 30, 2007.

  1. henry.oswald macrumors member

    Joined:
    Jul 14, 2007
    #1
    i'm missing something obvious here where do i go?
     
  2. Jaffa Cake macrumors Core

    Jaffa Cake

    Joined:
    Aug 1, 2004
    Location:
    The City of Culture, Englandshire
    #2
    In the Inspector, look under Text/More – there should be a language option in there which you can set to British English.
     
  3. henry.oswald thread starter macrumors member

    Joined:
    Jul 14, 2007
    #3
    thanks, anyway to save this? it seems to forget it on new documents.
     
  4. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #4
    Go to Edit - Spelling and Grammar - Show Spelling and Grammar

    at the bottom set it to British English, this will change the system wide spell checker to use British English.
     
  5. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
    #5
    I did it in the International preference pane, choosing Language, then Edit List, choosing British English and setting that :)
     
  6. MacGuyver macrumors member

    Joined:
    Nov 26, 2007
    #6
    Now somebody tell me how I can bloody well turn it off!
     
  7. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #7
    Been a Mac user for a year now and I've never managed to find out how to change the language to British English!

    Fantastic that I can now type colour without being told off :D
     
  8. CaptainHaddock macrumors 6502

    Joined:
    Jul 6, 2004
    Location:
    Nagoya, Japan
    #8
    If you're British, you should set your user's language in Preferences -> International to British English, and then it will always be the default language in Pages and elsewhere.
     
  9. jer16 macrumors newbie

    jer16

    Joined:
    Nov 12, 2008
    #9
    Thank you, thank you, thank you. How lovely to type "colour" and "realise" and have them accepted :)
     
  10. parish macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #10
    Strictly speaking, realize is not, contrary to popular belief, American spelling. The OED lists such words under ~ize, with ~ise as an alternative spelling. Twenty years ago it only listed them as ~ize
     
  11. Fruiteatingbear macrumors newbie

    Joined:
    Apr 27, 2007
    Location:
    Republic of England, Europe
    #11
    Parish is right.

    Words with a latin root are ~ise and those with a greek root are ~ize Though the British popular press seem to be intent on changing the way we spell. Well done the Times Literary Supplement, The Oxford University Press, Cambridge University Press and Encyclopedia Britannica for protecting our ~izes against the onslaught of the tabloid newspapers...
     
  12. djlard macrumors newbie

    djlard

    Joined:
    Apr 10, 2008
    Location:
    UK
    #12
    Easy fix for PAges 09 on Mountain Lion

    Sorted :p

    With pages doc open go to inspector, text, more, then select all the text and change to language of choice.

    Then go to Lang & text in main sys prefs and change your only lang option to your pref and system wide its done :)

    As of 08/12 this is ok on Mountain Lion and Pages :D
     
  13. MatthewBlack, Aug 24, 2013
    Last edited: Aug 24, 2013

    MatthewBlack macrumors newbie

    MatthewBlack

    Joined:
    Aug 24, 2013
    Location:
    London, UK.
    #13
    Thank you

    n/a

    ----------

    This worked for me. I went into System Preferences/ Language and Text/ then selected British English in the options menu. Then it prompted me that the systemwide language change would take effect next time i logged in and the changes would take effect for apps when they were started. :eek:
     
  14. B16EM, Sep 17, 2013
    Last edited: Sep 17, 2013

    B16EM macrumors newbie

    Joined:
    Feb 9, 2013
    Location:
    Mainland Britain
    #14
    British English

    Thank you, but..........

    I may at last have found my way through to the solution, thanks to guidance from other contributors.

    In the Language and Text Preference Pane, you must click Edit List, {thanks psychofreak missed it first time round,} under the <Drag languages into the order you prefer> list.
    Because British English is not checked in the checkbox by default, so it is in the hidden section.

    Having suffered Pages keeping random paragraphs as (American) English, despite Select All -----> British English, and only finding out later that the instruction is ignored, maybe.........

    I'm logging off and restarting with everything crossed.

    Sadly NO!

    Pages still thinks meter is a unit of measurement and colour a typo, and my Pages Edit Menu, only has Spelling in it, with no options to select any language. {Not Spelling and Grammar xUKHCx. It has Proofreading instead of Grammar.}

    Any further help would be appreciated, I've tried everything listed in this Rumour, and some of my own, I am beginning to think my version of Pages has bugs.
     
  15. B16EM macrumors newbie

    Joined:
    Feb 9, 2013
    Location:
    Mainland Britain
    #15
    British English: Not a Solution, but a possible reason.

    Further information.

    I have discovered what I suspect may be a bug in TextEdit which largely explains why Pages randomly reverts to American English in documents.

    It is in the Copy-->Paste procedures.

    If you have ALL your Applications set to British English, and your System Preferences also set to British English there is still a nasty lurking.

    You can compose text in TextEdit, British English.
    Copy it.
    Paste it into a Pages document in British English, and the pasted text will be in AMERICAN English.:mad:

    If you do not notice and correct immediately, that section may randomly remain as American English, even if you Select All, and change to British English in the Pages document.

    How do I draw Apple's attention to this suspected bug, please?
    Well, two suspected bugs, the Select All command obviously is buggy too.
     
  16. Moonjumper macrumors 68000

    Joined:
    Jun 20, 2009
    Location:
    Lincoln, UK
    #16
  17. B16EM macrumors newbie

    Joined:
    Feb 9, 2013
    Location:
    Mainland Britain
    #17
    British English and Possible Bug and Contacting Apple

    Thanks Moonjumper,

    I will follow the Link you gave me.

    Since posting I have nailed one bug hard down.

    It is in Pages 'Best Practice' document.

    Despite changing the Body text to British English; you must also change all styles, including those you create yourself, to British English, Individually.
    If you don't, your document will have access to an American Dictionary and challenge metre, colour etc. randomly in paragraphs affected by your Styles choices.

    This Randomly occurring paragraph problem is not reliably solved by Select All change to British English, so it is important to change All the styles that you intend to use before you begin serious work on your document.

    Thanks again for the help received,

    B16EM
     

Share This Page