How do you install leopard on Titanium powerbook w/667 mhz?

Discussion in 'macOS' started by macluv, Dec 2, 2007.

  1. macluv macrumors newbie

    Joined:
    Dec 2, 2007
    #1
    Anyone know? Its not officially supported, but Ive heard you can do it.

    Thanks!
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
  3. rdemby macrumors newbie

    Joined:
    Mar 8, 2008
    #3
    For those with 667Mhz PowerBooks (Or possibly other Macs that don't work with LeopardAssist):

    1.) Place the 10.5 Install disk in your drive.
    2.) Restart your Mac (don't use on the installer on the disk)
    3.) After the chime, hold down COMMAND+OPTION+O+F until you see a light gray screen with black text
    4.) let go of the keys and type in the following commands EXACTLY as shown, and hit the RETURN key after each line (you will see an "ok" confirming what you typed was correct):



    dev /cpus/PowerPC,G4@0
    d# 867000000 encode-int " clock-frequency" property
    d# 867000000 encode-int " min-clock-frequency" property
    d# 867000000 encode-int " max-clock-frequency" property
    multi-boot

    Select Leopard Install DVD
     
  4. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #4
    667Mhz is not worth the trouble to install Leopard on. It will run crazy slow. The 867 Mhz limit was set by Apple for a good reason. Tiger can work on legacy hardware but Leopard will be slow.
     
  5. rdemby macrumors newbie

    Joined:
    Mar 8, 2008
    #5
    I've done it and its speed is not "crazy slow" as you suggest. I suspect that you've not tried, but at any rate allow someone to try and then make their own assessment. I have run Photoshop effectively on my 667 PB. No beachballs. I do recommend using the max ram "1 GB" though.
     
  6. tugger macrumors regular

    tugger

    Joined:
    Apr 14, 2005
    Location:
    KTLH
    #6
    thanks

    Thanks for this. Exactly what I needed. It worked great on a Powerbook Ti 667MHz.
     
  7. jimpwg macrumors newbie

    Joined:
    Dec 15, 2008
    #7
    Has anyone tried this with Leopard 10.5.4?

    When I try it with my 667 titanium it fails on the DVD verification step.

    If i skip that step it fails when installing, it just hung at 12 minutes remaining.

    I tried creating a disk image on my fire wire drive to see if I could install it from there, but that wouldn't work either as it failed trying to create the disk image. I should have written exactly what is said, I think it couldn't find a directory. If no one has an idea of a fix I can rerun it.

    Could it be a problem with my optical reader? (I have tried two different disks).

    Thanks in advance...
     
  8. rdemby macrumors newbie

    Joined:
    Mar 8, 2008
    #8
    I'm up to 10.5.6 as of last night on my PB 667. I also had a install bump at 10.5.4, my system hung while upgrading. Did a new install with the archive option and then did a 10.5.4 combo update. You are using a original leopard install DVD?

    My system feels snappier and my Airport is definitely more robust.
    Good luck

    Robert
     
  9. jimpwg macrumors newbie

    Joined:
    Dec 15, 2008
    #9
    I am using an original 10.5.4 leopard install dvd.

    When you say you did a new install with the archive option, what level of leopard did you use?

    I am thinking I can't do a 10.5.4 combo update until I get a base OX install of Leopard, which I can't seem to do with my 10.5.4 dvd.
     
  10. rdemby macrumors newbie

    Joined:
    Mar 8, 2008
    #10
    I am using the 10.5.0 leopard dvd. I didn't realize later dvd install versions were updated to 10.5.4. If the firmware trick allows you to start the install
    then the DVD might have a nick or scratch or just be a little dirty which causes the verification step to fail or hang. Try cleaning the DVD and repeat the procedure.


    Robert
     
  11. jimpwg macrumors newbie

    Joined:
    Dec 15, 2008
    #11
    Unfortunately I am working off of my second dvd, the first one looked like it had some damage so I returned it.

    The second one looks cleaner, so I don't think that is it. Plus I cleaned it.

    I did do an erase and install, so I will try tomorrow to do the install with the archive option.

    If that fails I wonder if there is something funky in the 10.5.4 version...
     
  12. jimpwg macrumors newbie

    Joined:
    Dec 15, 2008
    #13
    Well I got it to work though I am not sure how...

    I restored Tiger, and tried an Archive and Install. It stalled at 46% complete and just hung. I waited awhile and gave up. I pushed the power on button a few times and went away while it was rebooting. Lo and behold when I came back up Leopard was up and running.

    So far it looks okay and I haven't seen anything not work.

    Thanks to all here for the help.

    I do have another problem though. I am trying to clone it to my firewire drive so that I have a backed up working copy. I was always able to do this with Tiger. I tried using Carbon Cloner 3.1.3 and super duper. Neither work, they both complete the clone, but won't boot. When I reboot holding down the option key I don't see the Leopard partition (I do see my Tiger partition) so I know the firewire drive is good. super duper fails and the log says "the partition does not have a valid mac os x system folder."

    Any ideas on why this fails? I have seen similar problems googling, but no solutions.

    Since it took so much work to get Leopard installed, I would like to back it up before I go too far...

    Thanks
     

Share This Page