How do you know if an app is 3.0 ready or not??

Discussion in 'iOS Apps' started by fuzion11, Jun 18, 2009.

  1. fuzion11 macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #1
    When selecting apps through the app store I notice that the majority seem to say "supports 2.x or higher".

    Some apps say supports 3.0

    So if I don't see supports 3.0 am I to assume that it won't work on 3.0

    Or does "2.x and higher" mean it will work with 3.x too??

    Please help someone, I need to know if I should install my iphone 3G apps tomorrow over to my iPhone 3GS...like ifitness and idiary and cro mag rally and such.


    Thanks guys!


    James
     
  2. Jeremy1026 macrumors 68020

    Jeremy1026

    Joined:
    Nov 3, 2007
    #2
    In theory, if it was built for 2.x it should work on 3.0. There will be times when that theory doesn't come though. But if you want to be 100% sure look for "iPhone OS 3.0 Tested" next to the version.
     
  3. fuzion11 thread starter macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #3
    REALLY???? WOW that sucks!

    I have so many apps that I love and hope will work flawlessly on 3.0

    I guess I'll just have to hope for the best...unless someone can confirm 100% that "2.X and up" means it will infact work on 3.0

    Thanks for helping out friends!
     
  4. Almy macrumors 6502

    Joined:
    Sep 27, 2008
    #4
    I haven't gone to great lengths to test everything, but so far all my apps have worked fine.
     
  5. Jeremy1026 macrumors 68020

    Jeremy1026

    Joined:
    Nov 3, 2007
    #5
    It depends on if the code used to write the apps hasn't been depreciated in 3.x to a point where it breaks the app. 99.9999% of your apps will work without a hitch.
     
  6. fuzion11 thread starter macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
  7. kwjohns macrumors 6502a

    kwjohns

    Joined:
    Jul 4, 2007
    #7
    Jamesdamon:

    For the past 2 months or so, all apps (new and updates) submitted to Apple had to work and be compatible with the 3.0 beta. So if your app doesn't work with OS 3.0 at all, then the developer of that app hasn't been very responsible in releasing an update within that time frame to ensure that it works.
     

Share This Page