How do you put music files on to your mac home page?

Discussion in 'MacBook Pro' started by sammyvine, May 9, 2013.

  1. sammyvine macrumors regular

    Joined:
    Aug 12, 2012
    #1
    I was trying to put itunes music onto my home screen of my macbook pro but when i do that, the song file also goes missing from the music folder.

    is there anyway you can put song files on to your home page without taking it out altogether from where your music is stored?
     
  2. mumph macrumors regular

    Joined:
    Apr 18, 2013
    #2
    Do you mean 'copy' it from iTunes to your desktop?

    Hold down the option/alt key when you drag the file and you should get a green '+' sign as you drag then drop it on your desktop.
     
  3. sammyvine thread starter macrumors regular

    Joined:
    Aug 12, 2012
    #3
    hey but when you do that, and you play that dragged song on itunes, your itunes library shows that song twice (the one in your folder, and the copied one i think)
     
  4. pat park macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    California
    #4
    If what you're trying to accomplish is launch a song/playlist from the desktop?
    You can export a playlist to the desktop. Save the file as an .m3u file. When you click that icon, it'll launch that playlist/songs.
     
  5. mumph macrumors regular

    Joined:
    Apr 18, 2013
    #5
    You've lost me there :confused: It sounds like you want to take music file out of iTunes but then play it from your desktop in iTunes?! Why not leave it in iTunes? The reason it shows up twice is because when you open it from the desktop it gets copied back into iTunes so you have two copies. You can turn that off in iTunes' preferences.
     
  6. sammyvine thread starter macrumors regular

    Joined:
    Aug 12, 2012
    #6
    yeah that's what i mean, how do i turn it off?
     
  7. mumph macrumors regular

    Joined:
    Apr 18, 2013
    #7
    Its under iTunes preferences called 'copy to library when importing' or something like that under the 'advanced' section. Untick it and iTunes will link to files instead of importing them. Be aware though this can cause quite a few problems with broken links if you then start moving the files around once they are linked in iTunes. Its best to copy to the library on importing.
     
  8. sammyvine thread starter macrumors regular

    Joined:
    Aug 12, 2012
    #8
    but when i put music on my desktop and i play them on itunes, that song appears twice...its kinda annoying to have two copies of that song
     
  9. mumph, May 21, 2013
    Last edited: May 21, 2013

    mumph macrumors regular

    Joined:
    Apr 18, 2013
    #9
    This is what I dont get. Why are you taking a song out of iTunes to then play it in iTunes?

    To drink coke from a can requires the coke to be in the can not in a cup. If you get my meaning.
     
  10. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #10
    Why don't you simply let iTunes manage your music and use the very useful search feature to play whatever you want much faster than having a ton of useless files on your desktop?

    I'm not sure I understand the purpose of doing what you're doing, if anything, you're slowing down your music flow by having to visually search for the proper file name on your desktop whereas iTunes will manage it all correctly from the get go.

    Please enlighten me, I simply cannot comprehend why you would even want to do it.
     
  11. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #11
    Go to itunes' preference>advance tab>uncheck "keep iTunes Media Folder Organized". Drag all your music to your DESKTOP (not home screen). Your music should still be in iTunes but it won't play because it's not linked to the correct location. Just delete them all then reimport them from your desktop.
     

Share This Page