How do you reinstall, if it will not recognize the install disc?

Discussion in 'MacBook Pro' started by lostarts, Aug 26, 2010.

  1. lostarts macrumors newbie

    Joined:
    Aug 26, 2010
    #1
    Hi there,
    I booted the MacBook in verbose safe mode and it appears I have some permissions issues; this is what I see:

    launchctl: Dubious permission on file (skipping): /Library/LaunchDaemons
    launchctl: Dubious permission on file (skipping): /System/Library/LaunchDaemons
    launchctl: Dubious permission on file (skipping): /etc/mach_init.d

    Now, from what googling I've done, it seems the only way to fix this is a fresh install. Only one problem - it will not boot the install disc when I hold "C" at power up.

    I've already done the reset (remove battery, hold power 5 sec) and also reset PRAM. Neither of these helped the system recognize the disc.

    It just keeps going straight to the gray screen with the Apple logo and spinning load prompt.

    Can anyone tell me how to get around this? I plan to install Tiger, then somehow access Time Machine (another issue all it's own).

    Any help is appreciated - thanks in advance :)
     
  2. mdnz macrumors regular

    Joined:
    Apr 14, 2010
    Location:
    The Netherlands
    #2
    When you power on your Mac, immediately press and hold the option key and wait for the DVD to arrive. After that, boot from it and repair the permissions.
     
  3. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
  4. oplix macrumors 65816

    oplix

    Joined:
    Jun 29, 2008
    Location:
    New York, NY
    #4
    If you are having issues booting from a OEM DVD than a faulty logic board/super drive might be at fault.
     
  5. Giuly macrumors 68040

    Giuly

    #5
    Don't reinstall, fix the permissions.

    Insert Install DVD, hold "C"-key on the keyboard while powering on the machine to boot from CD/DVD. The gray screen also appears it you boot from DVD, hold the key until you hear the optical drive spinning up. Select your language, hit Utils->DiskUtil from the top-menu, choose your "Macintosh HD", and click "Repair Disk Permissions".

    Reboot, done.

    Why installing Tiger? Tiger is as old as Windows XP. Install Snow Leopard for $29.
    My guess is that you're using a Tiger-DVD prior 10.4.4, thus no Intel-Support.
     
  6. DesmoPilot macrumors 65816

    Joined:
    Feb 18, 2008
    #6
    Amen, who uses optical media anymore?
     
  7. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #7
    <<raises hand>>
     
  8. lostarts thread starter macrumors newbie

    Joined:
    Aug 26, 2010
    #8
    "fixed" permissions in single user mode

    So, I thought I would try Giuly's suggestion, and I've been looking for a way to fix permissions.

    While I appreciate everyone's offer to help, it seems that I wasn't clear on one thing: The Mac is not recognizing the disc at startup

    I would love to be able to run "repair permissions", but it looks like I need a way around that. Here is what I've tried so far in single user mode:

    1. Ran fsck -fy
    2. mount -uw
    3. chmod 775/
    4. chmod 1775/

    I found another thread discussing permissions issues, but what worked for them is not working for me.

    I think my next step is to call my neighbor who hopefully has a firewire. From what I understand you can enter target mode and use disk repair from another computer - my wife's mac should be able to do the trick.

    In the meantime if anyone has a better idea on how to change permissions from single user mode, can you please share it? Or a way to use the install disc from single user mode could help to...

    As for the other suggestions, I wouldn't know where to begin creating a bootable USB and I'm pretty sure the logic board is ok. I'd love to be able to install applejack, but I think it's a bit late for that - though I'm not sure.
     
  9. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #9
    lol :)
     
  10. lostarts thread starter macrumors newbie

    Joined:
    Aug 26, 2010
    #10
    Scratch that - no firewire capability

    Well, I suppose the idea of using my wife's computer to repair permissions is out. I just checked, and her 13" Macbook has no firewire :(

    Oh well, if anyone can reply with some more single-user mode info, that would be awesome. Thanks much.

    Edit: I was able to get the Mac to recognize the disc by holding down the option key at startup. It didn't do much though, because it ran straight to the Apple logo with spinning loader, and eventually told me to restart. :( No dice.
     
  11. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #11
    I'll quote myself..
     
  12. larrycrutcher macrumors newbie

    Joined:
    Dec 15, 2008
    #12
    How do you do that if the drive will not read your Install DVD?

    Thank you,
    Larry
     

Share This Page