How do you setup iPhone to make calls on Mac/messaging?

Discussion in 'OS X Yosemite (10.10)' started by Rud3Bwoy, Oct 16, 2014.

  1. Rud3Bwoy Suspended

    Rud3Bwoy

    Joined:
    Oct 9, 2011
  2. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #2
    +1. Apple website says you need iOS 8 on your iPhone to have this feature, which I do, but still canʻt seem to make it work.
     
  3. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #3
    Facetime ->Preferences

    + iOS 8
     

    Attached Files:

  4. NavySEAL6 macrumors 6502a

    Joined:
    Dec 13, 2006
    #4
    I really wish they split making and receiving phone calls so you can pick and choose. I want to be able to make calls from Mac and iPad but I don't want them ringing when I'm getting a call.
     
  5. mactumors macrumors 6502

    Joined:
    Aug 3, 2008
    #5
    Also your Mac and iPhone have to be on the same WiFi network. That's why it's not working for me. My WiFi isolates devices.
     
  6. Rud3Bwoy thread starter Suspended

    Rud3Bwoy

    Joined:
    Oct 9, 2011
    #6
    can i be wired and have wireless turned on or i must get off the wired and leave wireless for it to work?

    ----------

    ok so just made a call from my mac but i hear the ring when they pick up must i use the phone to talk?its not allowing me to talk via micrphone on mac etc
     
  7. adversus macrumors regular

    adversus

    Joined:
    Sep 11, 2009
    Location:
    Portland, OR
    #7
    So the settings are both on in Mac OS and on my phone, bluetooth is on both and both are connected to same WiFi, but the phone call handoff isn't working.

    This is the feature I want the most :(
     
  8. superspud macrumors regular

    Joined:
    Dec 6, 2007
    #8
    yep cant figure it out either. I have no issues sending to people with iMessages but cant receive or send any with SMS.

    both on same wifi, my phone number is associated with my iCloud log in... cant figure it out...
     
  9. adversus macrumors regular

    adversus

    Joined:
    Sep 11, 2009
    Location:
    Portland, OR
    #9
    Just tested it and it IS working. To call out from your computer, go to Contacts and mouse over someone's phone number, and a blue phone icon should appear on the right.

    Also just got a call incoming to my phone and answered it on my rMBP. Woo.
     
  10. Rud3Bwoy thread starter Suspended

    Rud3Bwoy

    Joined:
    Oct 9, 2011
    #10
    i got it working can it be used to make calls to non people on contacts list?

    also what about sms messaging ?
     
  11. adversus macrumors regular

    adversus

    Joined:
    Sep 11, 2009
    Location:
    Portland, OR
    #11
    I think so. I set FaceTime as my outgoing call program and there's a window on the left side that allows you enter a regular number. I'd test it again but my phone is currently rebooting for the 8.0.2 update that I apparently never did.
     
  12. davelanger macrumors 6502a

    Joined:
    Mar 25, 2009
    #12
    SMS isn't until 8.1 I believe.
     
  13. Rud3Bwoy thread starter Suspended

    Rud3Bwoy

    Joined:
    Oct 9, 2011
    #13
    okay thanks for that
     
  14. Rud3Bwoy thread starter Suspended

    Rud3Bwoy

    Joined:
    Oct 9, 2011
    #15
  15. CEmajr macrumors 601

    Joined:
    Dec 18, 2012
    Location:
    Charlotte, NC
    #16
    Got this even working on my 2011 MBP. Pretty surprised. I was thinking we wouldn't be able to use this feature.
     
  16. Rud3Bwoy thread starter Suspended

    Rud3Bwoy

    Joined:
    Oct 9, 2011
    #17
    well everything is fixed waiting for the sms option now and ill be happy!
     
  17. duffman9000 macrumors 68000

    duffman9000

    Joined:
    Sep 7, 2003
    Location:
    Costa Mesa
    #18
    I see the option for Text Message Forwarding in iOS 8.1 beta. If you don't have that option in 8.0.x then you'll have to wait for 8.1 which should be out soon.
     
  18. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #19
    Figured it out...for me anyway...

    I had all the proper settings as shown above for the FaceTime App, but I still couldnʻt get calls to work. Figured out that itʻs an iPhone setting that was preventing it from working.

    1. iPhone and Mac need to be on the same wifi network
    2. Preferences in FaceTime need to be as shown in the post above.

    What made it work >>>

    3. On your iPhone go into Settings > FaceTime > and turn on > iPhone Cellular Calls.


    Go figure, it was the simplest thing that was preventing the call feature from working. Also, if youʻre a T-Mobile customer, the wifi calling feature in Settings > Phone > Wi-fi Calls > Allow Wi-Fi Calls must be turned off.

    Hope this helps!
     

    Attached Files:

    • 1.png
      1.png
      File size:
      116.1 KB
      Views:
      67
  19. Rud3Bwoy thread starter Suspended

    Rud3Bwoy

    Joined:
    Oct 9, 2011
    #20
    mines was always set to that for default odd lol
     
  20. SCOLANATOR macrumors 6502a

    SCOLANATOR

    Joined:
    Jul 3, 2013
    Location:
    UK
    #21
    Calling works perfectly well on my rMBP with the iPhone 5S but my only gripe so far is it wouldn't work with my high end Sennheiser headset + mic when plugged into the Bluetooth. Anyone have a way to make this work?
    Also does it work if I use my EarPods? Guess I'll test it out later.

    My only gripe was the quality of the audio wasn't great when using my rMBP's built in mic.
     
  21. nobodyjustwalks macrumors regular

    Joined:
    Jan 23, 2013
    #22
    Youʻre lucky. loll...took me over an hour to figure that one out. :p

    ----------

    Yea, Iʻd have to agree about the the audio quality. Perhaps itʻll get better over time as they update Yosemite.
     

Share This Page