How do you stop Windows XP from wanting to reboot?

Discussion in 'Windows, Linux & Others on the Mac' started by kkamin, Feb 16, 2010.

  1. kkamin macrumors member

    Joined:
    Mar 24, 2009
    #1
    Everytime I use Windows XP, there is some update that occurs. Then every 15 minutes a pop-up appears that wants to reboot the system. It is really annoying. How do you make the piece of ***** stop bugging me? Thank you.
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Reboot like it asks so it stops? Install ubuntu instead?
     
  3. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #3
    If it is calling for updates, I suppose you can either accept them or deny them
    Otherwise, you might want to consider scanning for a virus or malware
     
  4. kkamin thread starter macrumors member

    Joined:
    Mar 24, 2009
    #4
    No, it updates behind the scenes. It starts talking to me after it updates.

    I think it is weak if I need to load Windows, then reboot it every time I want to use it. There must be a way to disable its urge to reboot everytime it installs an update.

    ;P
     
  5. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #5
    That isn't possible. Because the prompt message to reboot is not due to your computer it's the application asking you to reboot. There is no trump all "no more reboots ever" kind of a fix. You need to find what the application is, and remove it if it annoys you that badly.
     
  6. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #6
    The updates you are receiving are evidently requiring a reboot
    Either that, or I am not understanding your issue clearly
     
  7. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #7
    You can turn off automatic updates, but you'll have to remember to do them manually.
     
  8. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #8
    Copy the text below into Notepad. Save it with a .reg extension. Open and confirm that you want to copy the data into your registry.

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "RebootRelaunchTimeoutEnabled"=dword:00000001
    "RebootRelaunchTimeout=dword:000000B4
    "NoAutoRebootWithLoggedOnUsers"=dword:00000000
    
    What these lines do are as following :
    Enable or disable the RebootRelaunch popup window
    0 - disables the RebootRelaunch timeout
    1 (default) - to enable the RebootRelaunch

    RebootRelaunchTimeout :
    Number of minutes to ask again (value in hex)
    A (default) = 10 minutes
    3C = 60 minutes [1 hour]
    78 = 120 minutes [2 hours]
    B4 = 180 minutes [3 hours]

    NoAutoRebootWithLoggedOnUsers = 1
    Enables or Disables the automatic rebooting if someone is currently logged into the machine.
    0 (default) = Allow the machine to reboot when someone is logged in.
    1 = Do NOT allow the machine to reboot when someone is logged in.


    With the settings in the .reg file above, the system will still do the automatic update and STILL pop up the window but if you click "reboot later" it will not ask again for 3 hours. This is how I prefer it to be since it does ask you a few times throughout the day as a reminder instead of you totally forgetting. But adjust it to anyway you want.
     
  9. codymac macrumors 6502

    Joined:
    Jun 12, 2009
    #9
    Open a prompt and issue the following command:

    net stop wuauserv
     

Share This Page