How do you turn off subs in VLC 2.0?

Discussion in 'Mac Apps and Mac App Store' started by THE dAY, Feb 21, 2012.

  1. THE dAY, Feb 21, 2012
    Last edited: Feb 25, 2012

    THE dAY macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #1
    Is there a way to have the subtitles Default to OFF for video files on VLC 2.0?

    I've searched and only found info on previous VLC versions.
    I've also played with the subtitle options in VLC's preferences with no luck.
    I'm running Leopard 10.5.8.

    Thank you!

    EDIT: Fix found, post #15
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Are you sure the video you're trying to watch doesn't have subtitles embedded (recorded onto the images)? If that's the case, you can't turn them off with any player.
     
  3. THE dAY thread starter macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #3
    Thank you GGJstudios,

    The subs are not embedded, I can turn them off manually but would like a way to have them off by Default.
    These are TV episodes in MKV format.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    I would expect that turning them off in Preferences should do the trick, but I no longer use VLC for movies and TV shows, so I can't be certain.
     
  5. MonkeyBrainz macrumors regular

    MonkeyBrainz

    Joined:
    Feb 18, 2012
    #5
    Preferences > Subtitles and OSD > uncheck 'Enable OSD'
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    :apple:
     
  7. THE dAY thread starter macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #7
    I tried that but subs are still there and I have to manually turn them off.

    Thanks for the suggestion though.
     
  8. MonkeyBrainz macrumors regular

    MonkeyBrainz

    Joined:
    Feb 18, 2012
    #8
    Unfortunately, they removed the option that I used to change in the settings to disable subtitles. In version 1.x you just set the default subtitle option to "0" (which means no subtitles turned on by default).

    I have no idea how to do this in version 2.0. Maybe switch back to version 1.x until you find some information on this online... unless someone here knows something.

    Scratching my head on this one, I feel stupid. lol
     
  9. THE dAY thread starter macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #9
    Thank you, I'll probably go back to previous version and I've actually tried something similar to what you mentioned but with no luck.

    In Preferences, Show All, under Input / Codecs:
    I changed Subtitles track from -1 to 0
    and changed Subtitles track ID from -1 to 0.
    Still get the subs.

    Thanks everyone for you help!
     
  10. MonkeyBrainz macrumors regular

    MonkeyBrainz

    Joined:
    Feb 18, 2012
    #10
    That would annoy me to no end. I don't know what to tell you. That always worked for me. :confused:
     
  11. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    As an alternative, if you haven't already, take a look at Plex as an alternative for managing and playing movies and TV shows. I've been very pleased with it.
     
  12. THE dAY thread starter macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #12
    You know what, I was just about to ask for alternatives... I will look into it right now, Thanks!
     
  13. MonkeyBrainz macrumors regular

    MonkeyBrainz

    Joined:
    Feb 18, 2012
    #13
    I prefer XBMC over Plex. Try both and see which one you like the best. Both are great, though.
     
  14. THE dAY thread starter macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #14
    Will check out XBMC as well, Thanks!
     
  15. THE dAY thread starter macrumors 6502

    Joined:
    Jul 22, 2010
    Location:
    SFV California
    #15
    Ok good news, I found another section in the VLC preferences for subtitles and there is the option for "Enable sub-pictures".

    I unchecked that and now subs are off by default.

    This seems to be the main subtitle settings option, before I was looking under "Input / Codecs".

    The attached pic shows the location in VLC preferences.

    Hope this helps anyone else looking to have subtitles of by default in VLC 2.0.
     

    Attached Files:

Share This Page