How does Airport prioritize WiFi connections?

Discussion in 'MacBook Pro' started by parish, Nov 5, 2009.

  1. parish macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #1
    My MBP 3,1 (early 2008?) normally just connects to my WLAN when I start it up but very occasionally it connects to a nearby WiFi Hotspot. When it does, turning Airport off then on again sometimes gets it to connect to my WLAN but sometimes it just keeps re-connecting the the hotspot. The only solution - and it works every time - is to reboot. But rebooting seems such a Windows thing to have to do.

    Does Airport "prioritize" its choice of connection, e.g. first tries to connect to the last WLAN it was connected to?

    One other thing. If I go into Network Prefs and click the Advanced button, I see my WLAN there but there seems to be no way to tell it to connect to that particular WLAN - the equivalent dialogue in Windows for example has a Connect button so you can select a WLAN and hit connect to force it to (try to) connect to that one, but there's no Connect button in OS X.

    In case it's important, I don't broadcast the SSID on my WLAN.
     
  2. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #2
    System preferences>Network>Airport>Advanced>Airport tab
     
  3. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #3
    To connect to a wireless network, do you not have the Airport icon on your top menu bar? Clicking on that should show you a list of nearby networks, and clicking on a particular network should join it.
     
  4. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #4
    From there you'll be able to drag/reorder which network you want AirPort to connect to first.
     
  5. parish thread starter macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #5
    Yes, that is the "Advanced" dialogue I was referring to in my OP. My WLAN is there - and top of the list - but very occasionally it just will not connect unless I reboot.
     
  6. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #6
    That's weird.

    Before you reboot next time, try turning your laptop's AirPort off for a few seconds and back on. Wonder if that'd accomplish the same thing as a reboot?
     
  7. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #7
    If it doesn't work, your airport .plist file might be messed up.

    Macintosh HD/Library/Preferences/SystemConfiguration

    and move the com.airport.preferences.plist to the trash (password is required)

    By doing so, you will have to re-enter all your passwords again for all networks.
     
  8. parish thread starter macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #8
    That works most of the time, but every so often it doesn't :confused:

    Thanks, I'll try that, although if this is the cause it seems curious (to me at least) that it manifests itself as an intermittent problem.

    As it is, it's not a great problem as it happens so infrequently it's just that having to reboot to fix something seems so Windows and un-Mac-like.
     

Share This Page