How does one install Cydia apps that require a reboot on a semi-tethered device?

Lycanthroat

macrumors regular
Original poster
Jan 11, 2011
148
0
UK
So, I messed up bigtime today and lost my untethered 5.0.1 JB and had to restore ;_; Not happy, but the phone kept respringing and I couldn't fix it. Even tried doing all that edit-the-host-file rubbish and it helped zippo.

So, I tried the 5.1 tethered JB, but I'm in a bit of a quandry. Apps like WinterBoard, SBSettings etc require a reboot, right? So, can I install them on the phone? If so, how would one go about this? Or am I better waiting for the "proper" JB for iPhone 4? I pressed "Reboot Device" anyway - like the stunningly clever person I am - and it went into another respring loop, so I had to restore again >.>

So, uh, some help would be appreciated. Thanks.
 

PsstGreek

macrumors 68040
Oct 21, 2010
3,772
58
Tampa Bay
With tethered jailbreaks every time your device reboots you need to run the software to turn it back on. Tethered mode.
 

Lycanthroat

macrumors regular
Original poster
Jan 11, 2011
148
0
UK
So, literally press the "Reboot Springboard" prompt that comes up after installing stuff in Cydia, connect to PC and use Redsnow to "Just Boot", correct?
 

PsstGreek

macrumors 68040
Oct 21, 2010
3,772
58
Tampa Bay
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Lycanthroat said:
So, literally press the "Reboot Springboard" prompt that comes up after installing stuff in Cydia, connect to PC and use Redsnow to "Just Boot", correct?
Yeah. No need to restore.
 

parrot5

macrumors 6502
Aug 10, 2010
393
22
So, literally press the "Reboot Springboard" prompt that comes up after installing stuff in Cydia, connect to PC and use Redsnow to "Just Boot", correct?
If it only prompts "Reboot Springboard", after the respring semi-tether is still active!!! No need to boot tethered.
 

Lycanthroat

macrumors regular
Original poster
Jan 11, 2011
148
0
UK
Thanks loads for the help guys - I installed stuff like SBSettings etc, then on the Cydia "Reboot Springboard" screen, I would just DFU and boot via Redsnow (worked fine).

I ended up going back to 5.0.1 thankfully (I had SHSH blobs saved I didn't know about) as Activator is MAJORLY buggy on 5.1. Also, it seems the shared artwork file is now different, because my custom one completely frizted the UI when I applied it.

Once again, you've all been very helpful :)

Cheers.