How does the Mac port of RA3 run on 9600GT

Discussion in 'Mac and PC Games' started by SebZen, Feb 28, 2010.

  1. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #1
    Title. Would it run smooth at 1440x900 on high?
     
  2. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
    #2
    Smooth enough. I usually play in Medium and that runs great. C&C3 in High and that runs great. Why different? Too lazy to change the settings. But always in full res. You should be fine.
     
  3. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #3
    Any chance you could please quickly check if it runs smooth on high? Also, is your 9600GT 256MB or 512?
     
  4. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
  5. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
    #5
    OK, I take that back. Didn't seem very happy. Runs on High in Windows though. I guess that's what you get with Cider ports.
     
  6. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #6
    I see, thanks for checking. That's what I was afraid of. Guess I'll get the Windows version
     
  7. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
    #7
    Just my opinion, obviously, and I don't know how much time you spend in Windows, but I find the graphical drop to be worth not having to boot into Windows each time I feel like playing.

    If you want some extra info on what settings look like what, try this site:
    http://www.pcgameshardware.com/aid,...gs-compared-plus-system-requirements/Reviews/
    Shows a really good comparison of all the preset graphics options.
     
  8. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #8
    Quite a big difference between medium and high to me :eek:

    Ultra high and high on the other hand, I don't see any difference at all. But medium to high is really big.

    For you on medium, are there any slowdowns at all? Or is it constantly smooth?
     
  9. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
    #9
    Very smooth, unless you have a tank swarm of 100+
     
  10. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #10
    OK just two more questions:

    1. What kind of a performance drop do you get from medium to high? Lower frames, or does it kind of freeze now and then for a second?
    2. 2GB or 4GB?
     
  11. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
  12. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #12
    Sorry to bother you again :)

    But could you please try one more thing for me?

    See if setting "SHADER" to medium while the rest set on high (with no AA) make it playable again?
     
  13. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #13
    I caved in and bought it from D2D. Sadly it's a piece of crap. Somehow it manages to run at the same ~20FPS on high, medium AND low.

    All high is kinda choppy, but setting shaders and water to medium gives me the exact same performance as putting everything to low. But it's still at ~20FPS or so. Definitely not smooth.

    Not only that, it tears like a mofo. And I can't turn Vsync on, otherwise my frames drop to ~10.

    Screw that. At least the Mac cd key works on the Windows version as well. So if you know what I mean I'll just get the Windows version and stick with that.
     
  14. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
    #14
    Seriously, what are your specs? I get choppy on High, but definitely smooth on Medium. I can even play acceptably on Medium with the 9400M switched on instead, and that's a much lower card.
     
  15. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #15
    Weird. I definitely can't play on medium on the 9400M. I can on Low and it's pretty smooth but medium I get ~5FPS.

    My specs are 2.4GHz, 9600GT 256MB, 4GB, 7200K RPM hard drive
     
  16. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
    #16
    What OS? Is your hard drive nearly full? Doesn't make much sense to me. You should be running much faster than that. I've seen others on this site also mention running on a 9400M. There must be some way to speed up. Although yes, worst case you can revert to Windows with your current SN. Like I said before though, Windows on high was about as smooth as Mac on Medium (due to cider), so if it works there you know there's something slowing your Mac side down.
     
  17. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #17
    10.6.2 and have 65GB available still.

    Are you running at 1440x900 or lower? That's a big factor as well. I'm running at 1440x900 (native res).

    And I just found this YouTube video of a person playing the game on his Mac Mini (9400M) and his options are all set to low and 1024x768: http://www.youtube.com/watch?v=_B9QON7abrM
     
  18. Ainze macrumors regular

    Ainze

    Joined:
    Feb 28, 2010
    #18
    Native res, 1440x900. Never lower. Either card. Do you definitely have the 9600 switched on?
     
  19. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #19
    Yup. And just to make sure it actually works I switched to the 9400M and last night and while the 9600GT was barely playable at medium, the 9400M was not at all playable.

    I'll install the Windows version tonight and report back with the results.
     
  20. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #20
    Same exact performance. I take it back though, both work fine with Vsync at medium.

    I guess it's the 30 FPS engine frame limit that gives the choppy feeling.

    But on the Cider port, the description box text is pretty funky. In Windows it's fine but not on OS X. Guess the font they used for Cider is the culprit
     

Share This Page