How I fixed my internal microphone

Discussion in 'MacBook Pro' started by JSchwage, Jan 8, 2008.

  1. JSchwage macrumors 6502a

    JSchwage

    Joined:
    May 5, 2006
    Location:
    Rochester, NY
    #1
    So the other day I booted up into OS X and was going to make a short video in Photo Booth with my friend. I recorded a video, but when I tried to play it back there was no sound. I tried recording another video, this time yelling at the top of my lungs. This time when I played it back, I could hear my yelling very faintly.

    I decided to open up the System Preferences to see if the microphone was picking up any sound. The input level showed that there was a little bit of static, but the bar barely moved when I yelled.

    Here's where it gets weird. I opened up Skype and called "echo123" to see if Skype was picking up and sound. After the call recorded my sound, it played it back and to my surprise it sounded perfect. It was like my microphone didn't have a single problem.

    I then opened up Photo Booth again and the System Preferences to see if it would pick up and sound from my microphone. And once again it would only barely pick up sound when I was yelling.

    After a few minutes, I finally decided I'd take my MacBook to the Apple Store. But before that, I decided I'd just try a little trick that worked on my iPod earbuds when one of them wasn't working correctly. I flicked my finger against the plastic right next to where the microphone is above the screen. I opened up System Preferences and to my amazement my microphone was now working perfectly! :eek:

    This is definitely one of the weirdest problems and actually the only problem I've had with my MacBook so far. I just thought I'd share this experience for any other people who might be having problems with their internal microphone.
     
  2. pmariki macrumors newbie

    Joined:
    Jun 2, 2009
    #2
    How I fixed my internal microphone

    You are right !! It works!!!:)

    Using my finger I flicked the mic on top of the screen...VOILA...mic is working!!
    thanks for the tip :)
     
  3. JamesGorman macrumors 65816

    JamesGorman

    Joined:
    Dec 31, 2008
    Location:
    Winnipeg
    #3
    That is weird, does flicking it cause something to go back into place? hmmm, seems a little odd lol, but hey, whatever works.
     
  4. bphillips macrumors regular

    Joined:
    May 31, 2009
    #4
    I bet it just knocks the dust out.

    I clean my mac once a month (so it doesn't get filled with dust)
     
  5. mikes70mustang macrumors 68000

    mikes70mustang

    Joined:
    Nov 14, 2008
    Location:
    US
  6. CathyRose macrumors newbie

    Joined:
    Jan 15, 2010
    #6
    How I fixed my internal microphone

    Thanks for sharing the experience, JSchwage. The "technical tap" worked for me, too! Awesome tip! Thanks!
     
  7. Strangechilde macrumors newbie

    Joined:
    Apr 15, 2010
    #7
    Goodness! I was having a similar problem: the internal microphone was simply not working. It picked up no sound, even if I yelled really quite loudly at it. Additionally, in the System Preferences, the mic was showing up as 'External microphone', type 'built in', rather than internal. There was no additional microphone plugged in and there were no internal ones showing up to select.

    I flicked it with my finger just like you said and it worked immediately! Showing up correctly in System Prefs, everything! Thank you-- you saved me a trip to the Apple Store. Not that I mind going there, but this is much easier!
     
  8. Island Preacher macrumors newbie

    Joined:
    Dec 9, 2009
    #8
    Photo Booth and the internal microphone

    I'm not specialist, but I think that there are conflicting interrupt switches that keep the microphone from working when it is being used by another program. I came here to find a solution. Flicking my computer did not work.

    I think this is the problem. I use Skype daily and naturally, it uses the microphone. Skype is always in memory, so it has command of the microphone. Then when I call up Photo Booth, the microphone does not work with Photo booth because Skype got it first.

    Solution: I quit both Skype and Photo Booth. I reloaded Photo Booth, et voilà, ça marche ! Quitting Skype or any other program which uses the microphone, releases the mic for Photo Booth. Hope this helps.
     
  9. Ronnoco macrumors 68030

    Ronnoco

    Joined:
    Oct 16, 2007
    Location:
    United States of America
  10. bagelsrock macrumors newbie

    Joined:
    Jan 12, 2011
    #10
    Wow.

    I'm really surprised. It actually worked. It was weird because the bars would go up and down showing that the mic heard me, but if i recorded something and tried to listen to it, it was just static, like it couldn't pick up the sound. But i tapped it, and now it works. Weird.
     
  11. alt macrumors regular

    Joined:
    Feb 12, 2008
    Location:
    Bend, Oregon
    #11
    Lulz......sounds like some bad wiring in there. If your still under apple care..might as well get them to fix it.
     
  12. badweather macrumors newbie

    Joined:
    Aug 25, 2011
    #12
    My MacBook Pro isn't a television from 1950

    If your mic works for some programs, and not for photo booth then no amount of tapping (technical or otherwise) or dust falling (in or) out will save (or kill) your computer.

    The only thing I could think of with the tapping is that it woke up because it "heard" you and responded by giving control back to sound booth because it also "heard" that program calling...

    More than likely there was a program that had grabbed the volume control. I have Adobe sound booth hog the mic all the time. Have to go in and specifically tell it to give it up to photo booth.

    I find photo booth a great way to make quick and dirty sketch tracks of my cello and my friends computer sounds. Though this evening it was rather frustrating.... so I found your erroneous posting to which I found myself compelled to reply... sorry.

    closing and re-opening photo booth after telling Adobe sound booth to "give it up" was probably what solved this problem.
     
  13. ben4010 macrumors newbie

    Joined:
    Oct 9, 2011
    Location:
    Christchurch, New Zealand
    #13
    Thanks :)

    Thanks i had the same problem and this worked. Thanks again :D
     
  14. PianoFanatic macrumors newbie

    Joined:
    Feb 11, 2012
    #14
    Thanks for your help but.....

    Hey thanks for the advice of flicking the internal mic, I did this on my iPod touch, and the sound picked up a bit more but there's loads of static sound over my voice so it's still hard to hear. Any advice?? Please !
     
  15. nickir macrumors newbie

    Joined:
    Mar 25, 2014
    #15
    Another simple reason

    Hi, I want to thank you for this simple flicking trick, it did help me figure out that the microphone inside was actually detecting sound but something was stopping sound getting in. I realised only just now that the microphone is a tiny pin hole above the camera on my iMAC and that I had a piece of sticky tape covering it up! Would never have realised if I didn't first try flicking. hehehe:)
     
  16. iDeba macrumors newbie

    Joined:
    Aug 28, 2014
    Location:
    Pondicherry
    #16
    Same problem here

    I have got the same problem but instead I have got a MacBook Pro in which the mic is hidden underneath the left side speaker. I did all the flicking but had no luck.
    If anyone here knows what could be wrong kindly help me out.
    Model Specifications: Macbook Pro A1286 Late 2011, i7, 750GB.
    Seeing the success rate of this particular "flicking" cure I have been trying it on the left side speaker for a while now but so far have only got a sore Nail-tip.
     
  17. PrashantVaze macrumors newbie

    Joined:
    Mar 1, 2015
    #17
    Hi iDeba - MBP microphone not picking up sound

    Did you ever fix your problem with the microphone? I have the same MacBook Pro as you and the same problem. I've tried PRAM reset etc but not picking up any sound at all
     

Share This Page