How I learned mouse drivers are the source of all the worlds evil

Discussion in 'Mac Basics and Help' started by Klungo, Jul 29, 2009.

  1. Klungo macrumors newbie

    Joined:
    Jun 10, 2009
    #1
    Hello, all! A month or so I got an iMac and it's been pretty awesome, despite two dead pixels!

    Today I wonder if perhaps I'm beyond help, and how in the world this could happen.

    This story begins with me using my Logitech MX Revolution mouse. It's a nice mouse, I really like it! When I first go the mac I promptly went to Logitech's site and downloaded the official logitech control center and everything worked out fine. Until a day ago, when I read that the logitech drivers are sort of sloppy, and using an utility such as USB overdrive, or steermouse would be better. So I followed that advice! (I decided to go for steermouse, as it looked to be more recently updated)

    I uninstalled the logitech pref pane, and installed steermouse. This is where my troubles began. I couldn't quite seem to get the mouse to work properly, no matter what I tried on the menu. So I decided that, well, I guess this program is crap, and uninstalled it. When I went to reinstall the logitech pref pane, things started getting weird.

    It started with it unable to recognize my mouse, no matter what I did. It was weird, but I could probably find a solution to that. But then I noticed this odd black bar that seemed to impose itself on every selection I make, which I assume is one of the easier things to disable, if I knew how.
    http://img40.imageshack.us/img40/5736/picture1tns.png
    But then I noticed some other things.

    http://img34.imageshack.us/img34/7237/picture2caa.png

    Such as that, which strikes me as odd.

    So I figured that I've really messed something up, and went to install ONYX, and tried it out. Did everything it could do, and found it didn't change anything.

    No problem, I say to myself in sheer ignorance, I'll just use my time machine backup to restore my previous settings! That was before my external HD crashed. (Calvary is a bad brand, I've discovered!)

    So now I'm stuck with all of this, and feeling mighty stupid.

    I guess the moral of this story is stick with logitech, or something.

    Help?
     
  2. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #2
    ... and the moral of the story is to not download and install random software unless you are 100% sure it won't screw your machine over ;)

    Do you have Time Machine backups to restore to?
     
  3. Klungo thread starter macrumors newbie

    Joined:
    Jun 10, 2009
    #3
    So that's a no.
     
  4. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #4
    Well, as your current drive still works, I'd reccomend you copy all the data you want to save to a new external (I recommend WD's passport line if you want a small drive) and reinstall OSX.
     
  5. killerrobot macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #5
    I'd uninstall the logic tech pref. pane, and the mouse in system preferences.
    Use onyx to clear the cache and then restart and reset the PRAM.
    Connect the mouse. Hope all is back to normal.
    If that doesn't work, then I'd reinstall the OS.

    Best of luck.
     
  6. Klungo thread starter macrumors newbie

    Joined:
    Jun 10, 2009
    #6
    None of that seemed to help any, so it looks like I'll have to get another external HD and then reinstall OS X.

    Thanks for trying, though!
     
  7. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
  8. Klungo thread starter macrumors newbie

    Joined:
    Jun 10, 2009
    #8
    Multiple times, yes.

    Although in a last ditch effort I am pleased to report I've gotten most things back to normal, which means no OS x reinstall! (The mysterious black bar AND the multiple shut down prompts were fixed by..turning off universal access. I guess I should unplug the headphones when I'm not using them)

    So that's one boring mystery solved. Let's see if I can get the mouse back to normal.
     

Share This Page