How is this possible? (MacBook won't recognize battery)

Discussion in 'MacBook Pro' started by iEugene, Aug 11, 2007.

  1. iEugene macrumors regular

    iEugene

    Joined:
    Apr 18, 2006
    Location:
    AZ
    #1
    My friend has a MacBook that has worked flawlessly for months, until one day it suddenly wouldn't turn on, unless you plugged the MagSafe adaptor in. If the power supply comes out, the computer shuts down instantly.

    The picture in her top right menu bar is this when plugged in with the MagSafe

    [​IMG]


    Notice how the symbol where the battery is supposed to be is just an X. I have NEVER seen this and am not sure if there is anything I or her can physically do to solve it, other than sending it back to Apple.

    Does anyone have any advice or thoughts of what to do? Or is this a "send it to Apple" thing?
     
  2. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #2
    you get this "x" when the battery isn't connected to the macbook/macbook pro. this is something you need to send to apple to fix. there's something preventing the macbook from registering the battery, and apple needs to fix it. the other possibility i can think of is that the batter is completely dead. maybe you could try putting in another macbook battery to see if the problem still occurs.
     
  3. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #3
    this happens when i unplug my battery, the X comes up. i have no idea why this is no longer working when the battery is plugged in. maybe take it in to apple and show them, might get a new battery out of it :)
     
  4. noodle654 macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #4
  5. devman macrumors 65816

    devman

    Joined:
    Apr 19, 2004
    Location:
    AU
    #5
    Exact same thing happened with my son's computer. It was working flawlessly for months too. Take it in. My battery was swapped without them even looking at it.
     
  6. wolverinewizard macrumors member

    Joined:
    Aug 2, 2007
    #6
    I had this problem a few months back. It occurs if your battery drains all the way down and the macbook shuts off; the next time you turn it on it won't recognize the battery anymore and you get that lovely 'x'.

    I guess it's a known issue; I thought that there was a firmware update that fixed it? Regardless, all I did was go see a mac genius at an apple store. He swapped out my battery and I was out of there in 15 minutes.
     

Share This Page