how long should it take for an external USB drive to mount?

Discussion in 'Mac Accessories' started by glitch44, May 31, 2007.

  1. glitch44 macrumors 65816

    Joined:
    Feb 28, 2006
    #1
    I have an 80gig external USB (2.0) drive.
    I recently formatted it as HFS+ and copied documents / photos / etc over.

    It was fine the first couple days I turned it on. Mounted in a couple seconds.
    But after I manually forced a spotlight index (which took 2+ hours) now when I turn it on it takes 2-3 minutes before the icon appears on the desktop.

    Is this normal? Or does my drive have a problem?
     
  2. Young Ted macrumors newbie

    Joined:
    May 19, 2007
    #2
    Sounds a bit fishy. Why did you force a reindex anyway? It shouldn't be taking that long to mount.

    Does the drive make weird noises when you plug it in and you're waiting for it to mount? If it makes odd noises then it could be a bad drive.

    Do you have any other USB devices (apart from keyboards and mice) attached? Try unplugging other things.

    Are you connecting through a hub? Plug it directly into the computer and see if that helps.

    Have you tried restarting, or logging out/in again? Might do something, who can say.

    What happens when you plug it into another computer?

    As a last resort, you could try reformatting the drive and copying things over again.

    If after all that it still takes ages, then perhaps it's bad. Could be the drive or the USB magic inside.
     

Share This Page